summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 29 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3e0bc6a74d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = ifp-console
+ pkgdesc = IFP | Infinite Fusion Project - console desktop app
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/wxn0brP/ifp-console
+ arch = x86_64
+ license = MIT
+ source = https://github.com/wxn0brP/ifp-console/releases/download/v0.0.1/ifp-console
+ sha256sums = 43841e6c0bc67f248c36ea759016a9088ddac20e126eae118b95a3f0c49628a5
+
+pkgname = ifp-console
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7f12648f846
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=ifp-console
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="IFP | Infinite Fusion Project - console desktop app"
+arch=('x86_64')
+url="https://github.com/wxn0brP/ifp-console"
+license=('MIT')
+depends=()
+makedepends=()
+source=("https://github.com/wxn0brP/ifp-console/releases/download/v$pkgver/ifp-console")
+sha256sums=('43841e6c0bc67f248c36ea759016a9088ddac20e126eae118b95a3f0c49628a5')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ mv "$srcdir/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ chmod +x "$pkgdir/usr/bin/$pkgname"
+}
+