summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD31
2 files changed, 15 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 05a58d6122d1..d1f777c1d8b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = ifrextractor-ls
- pkgdesc = Utility that can extract the internal forms represenation from both EFI and UEFI modules
+ pkgdesc = Extracts the internal forms represenation from both EFI and UEFI modules
pkgver = 0.3.7
pkgrel = 1
url = https://github.com/LongSoft/Universal-IFR-Extractor
@@ -10,7 +10,6 @@ pkgbase = ifrextractor-ls
provides = ifrextractor
conflicts = ifrextractor
source = https://github.com/LongSoft/Universal-IFR-Extractor/archive/0.3.7.tar.gz
- md5sums = 25b007a65fb7761c3bfb7a48d3d928ad
+ sha256sums = 76b38c5ab7e23f732f1ed4ea9b6183fbf0d9bb5550a6be62326306b45c128b38
pkgname = ifrextractor-ls
-
diff --git a/PKGBUILD b/PKGBUILD
index 0957f4b6a09c..a68a3b5ed14a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,24 @@
pkgname=ifrextractor-ls
pkgver=0.3.7
pkgrel=1
-pkgdesc='Utility that can extract the internal forms represenation from both EFI and UEFI modules'
-arch=('any')
+pkgdesc='Extracts the internal forms represenation from both EFI and UEFI modules'
+arch=(any)
url='https://github.com/LongSoft/Universal-IFR-Extractor'
-license=('GPL3')
-makedepends=('cmake' 'git')
-provides=('ifrextractor')
-conflicts=('ifrextractor')
+license=(GPL3)
+makedepends=(cmake git)
+provides=(ifrextractor)
+conflicts=(ifrextractor)
source=("${url}/archive/${pkgver}.tar.gz")
-md5sums=('25b007a65fb7761c3bfb7a48d3d928ad')
-
-prepare() {
- cd Universal-IFR-Extractor-${pkgver}
- mkdir -p build
- cd build
- cmake ..
-}
+sha256sums=('76b38c5ab7e23f732f1ed4ea9b6183fbf0d9bb5550a6be62326306b45c128b38')
build() {
- cd Universal-IFR-Extractor-${pkgver}/build
- make
+ cmake -S Universal-IFR-Extractor-${pkgver} -B build \
+ -DCMAKE_C_FLAGS:STRING="$CFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$CXXFLAGS" \
+ -DCMAKE_EXE_LINKER_FLAGS:STRING="$LDFLAGS"
+ make -C build
}
package() {
- cd Universal-IFR-Extractor-${pkgver}/build
- install -Dm755 ifrextract -t "$pkgdir"/usr/bin
+ install -Dm755 build/ifrextract -t "$pkgdir"/usr/bin/
}