summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--Changelog5
-rw-r--r--PKGBUILD19
4 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..994ae7268353
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ignore
+ pkgdesc = Download .gitignore files for a given language.
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/jarodl/ignore
+ changelog = Changelog
+ arch = any
+ license = MIT
+ depends = python2
+ depends = python2-distribute
+ conflicts = ignore-git
+ source = http://pypi.python.org/packages/source/i/ignore/ignore-0.1.4.tar.gz
+ md5sums = 4b3d9ddf4675aa827ed5d1f6867ee444
+
+pkgname = ignore
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4e66f2a71ed7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar*
+*.zip
+.AURINFO
diff --git a/Changelog b/Changelog
new file mode 100644
index 000000000000..e7915fd8be6e
--- /dev/null
+++ b/Changelog
@@ -0,0 +1,5 @@
+2012-01-21 Julien Nicoulaud <julien.nicoulaud@gmail.com>
+
+ * 0.1.4-1 :
+ Initial release of the package.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0d9dfbffb13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Julien Nicoulaud <julien.nicoulaud@gmail.com>
+# Source: https://github.com/nicoulaj/archlinux-packages
+pkgname=ignore
+pkgver=0.1.4
+pkgrel=1
+pkgdesc="Download .gitignore files for a given language."
+arch=(any)
+url="https://github.com/jarodl/ignore"
+license=(MIT)
+depends=(python2 python2-distribute)
+changelog=Changelog
+conflicts=(${pkgname}-git)
+source=("http://pypi.python.org/packages/source/i/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('4b3d9ddf4675aa827ed5d1f6867ee444')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}