summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO12
-rwxr-xr-xPKGBUILD13
-rwxr-xr-xiicalc.install16
3 files changed, 18 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb23467d8c6c..11aaa5a675a2 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = iicalc
pkgdesc = An extensible calculator written in Python.
- pkgver = 2.4.15
+ pkgver = 2.13.0
pkgrel = 1
url = https://gitlab.com/TurboWafflz/ImaginaryInfinity-Calculator
install = iicalc.install
arch = any
- groups =
license = GPL
- makedepends = binutils
makedepends = tar
- depends = python
+ depends = bash-completion
depends = python-pip
- optdepends = dialog: GUI elements
+ depends = dialog
conflicts = iicalc-beta
options = !strip
options = !emptydirs
- source = iicalc-2.4.15.deb::https://gitlab.com/TurboWafflz/ImaginaryInfinity-Calculator/-/jobs/artifacts/master/raw/iicalc.deb?job=debian%20packager
- sha512sums = 06d27b63eb5991fc68702fb1235c114515122f1dbe3a56c9cf703635aaa04034cb65625d7978da269efe9cd6e9ee321242836956323e42d9d439cc0022caaa1d
+ source = iicalc-2.13.0.deb::https://gitlab.com/TurboWafflz/ImaginaryInfinity-Calculator/-/jobs/artifacts/master/raw/iicalc.deb?job=debian%20packager
+ sha512sums = 644e2f1d842716b958a4a8a7b4495f27721c498748dc5c51e8d1e3908c5c9f5316a97f981e652eb8de38ca0930efac61b033407cd316ca514b29b915fff4ff8a
pkgname = iicalc
diff --git a/PKGBUILD b/PKGBUILD
index c5045aa254fe..e3d16e1f7981 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,26 @@
-# Generated by debtap
# Maintainer: tabulatejarl8@gmail.com <TabulateJarl8>
# Maintainer: TurboWafflz <turbowafflz@gmail.com>
pkgname=iicalc
-pkgver=2.4.15
+pkgver=2.13.0
pkgrel=1
pkgdesc="An extensible calculator written in Python."
arch=('any')
url="https://gitlab.com/TurboWafflz/ImaginaryInfinity-Calculator"
license=('GPL')
-groups=('')
-depends=('python' 'python-pip')
-optdepends=("dialog: GUI elements")
-makedepends=("binutils" "tar")
+depends=('bash-completion' 'python-pip' 'dialog')
+makedepends=("tar")
conflicts=("iicalc-beta")
options=('!strip' '!emptydirs')
install=${pkgname}.install
source=("iicalc-$pkgver.deb::https://gitlab.com/TurboWafflz/ImaginaryInfinity-Calculator/-/jobs/artifacts/master/raw/iicalc.deb?job=debian%20packager")
-sha512sums=('06d27b63eb5991fc68702fb1235c114515122f1dbe3a56c9cf703635aaa04034cb65625d7978da269efe9cd6e9ee321242836956323e42d9d439cc0022caaa1d')
+sha512sums=('644e2f1d842716b958a4a8a7b4495f27721c498748dc5c51e8d1e3908c5c9f5316a97f981e652eb8de38ca0930efac61b033407cd316ca514b29b915fff4ff8a')
package(){
# Extract package data
- ar vx iicalc-$pkgver.deb
tar xf data.tar.xz -C "${pkgdir}"
rm debian-binary control.tar.xz data.tar.xz
sed -i -E 's/debian/aur/' ${pkgdir}/usr/share/iicalc/config.ini
+ sed -i -E 's/checkupdates = true/checkupdates = false/' ${pkgdir}/usr/share/iicalc/config.ini
}
diff --git a/iicalc.install b/iicalc.install
index a69622e2f069..9cb0d2eb46b6 100755
--- a/iicalc.install
+++ b/iicalc.install
@@ -1,15 +1,15 @@
post_install() {
- chmod +x /usr/bin/iicalc
- pip3 install -r /usr/share/iicalc/requirements.txt
- #if type xdg-mime > /dev/null; then
- #xdg-mime default iicalc.desktop x-scheme-handler/iicalc
- #fi
+
+chmod +x /usr/bin/iicalc
+pip3 install -r /usr/share/iicalc/requirements.txt
+#if type xdg-mime > /dev/null; then
+ #xdg-mime default iicalc.desktop x-scheme-handler/iicalc
+#fi
}
-
post_upgrade() {
post_install
}
-
pre_remove() {
- echo -e "\033[38;5;11mWarning: Removing ImaginaryInfinity Calculator does not remove the .iicalc folder in your home directory. If you want to run the portable version of ImaginaryInfinity Calculator again, you will have to delete it.\033[m"
+
+printf "\033[38;5;11mWarning: Removing ImaginaryInfinity Calculator does not remove the .iicalc folder in your home directory. If you want to run the portable version of ImaginaryInfinity Calculator again, you will have to delete it.\033[m\n"
}