summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 24 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24e0766c433e..c6218e2fc904 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = infrared-git
pkgdesc = A generic C++/Python hybrid library for efficient (fixed-parameter tractable) Boltzmann sampling.
- pkgver = 0.3.r7.gec411b9
- pkgrel = 2
+ pkgver = 0.4.r0.g2af827c
+ pkgrel = 1
url = https://github.com/s-will/Infrared/
arch = x86_64
groups = viennarna-package
@@ -11,6 +11,9 @@ pkgbase = infrared-git
makedepends = doxygen
depends = htd
depends = boost-libs
+ depends = python
+ optdepends = python-networkx: fallback tree decomposition
+ optdepends = tdlib: alternative to libHTD tree decomposition
optdepends = python-rna: required by redprint.py
provides = libinfrared.so
provides = libhtdwrap.so
diff --git a/PKGBUILD b/PKGBUILD
index d1511fd4fe76..48326dcc2544 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,22 @@
pkgname=('infrared-git')
pkgName=('Infrared-git')
-pkgver=0.3.r7.gec411b9
-pkgrel=2
+pkgver=0.4.r0.g2af827c
+pkgrel=1
pkgdesc="A generic C++/Python hybrid library for efficient (fixed-parameter tractable) Boltzmann sampling."
arch=('x86_64')
url="https://github.com/s-will/Infrared/"
license=('GPL3')
groups=('viennarna-package')
depends=('htd'
- 'boost-libs')
+ 'boost-libs'
+ 'python')
makedepends=('git'
'boost'
'doxygen')
-optdepends=('python-rna: required by redprint.py')
+optdepends=('python-networkx: fallback tree decomposition'
+ 'tdlib: alternative to libHTD tree decomposition'
+ 'python-rna: required by redprint.py')
provides=('libinfrared.so' 'libhtdwrap.so' 'redprint.py')
conflicts=('infrared')
source=("Infrared::git+${url}#branch=master")
@@ -51,4 +54,16 @@ package() {
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
mkdir -p "${pkgdir}${site_packages}"
ln -st "${pkgdir}${site_packages}" /usr/lib/libhtdwrap.so /usr/lib/libinfrared.so
+
+ for pymodule in \
+ infrared.py \
+ rna_support.py \
+ treedecomp.py \
+ redprint.py \
+ redprint_complexity.py
+ do
+ mv "${pkgdir}/usr/bin/$pymodule" "${pkgdir}${site_packages}"
+ done
+
+ ln -st "${pkgdir}/usr/bin/" "${site_packages}/redprint.py" "${site_packages}/redprint_complexity.py"
}