summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--INJECTION_0.9.4_src.zip.md51
-rw-r--r--PKGBUILD69
-rw-r--r--injection.desktop2
4 files changed, 47 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fbf37c1f217..4cde5fbf8aa6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,25 @@
pkgbase = injection
- pkgdesc = A Python-based ASCII programming-puzzle game.
- pkgver = 0.9.4
+ pkgdesc = Python-based ASCII programming-puzzle game
+ pkgver = 0.10.2
pkgrel = 1
- url = https://schilcote.itch.io/injection
- arch = i686
+ url = https://toastengineer.itch.io/injection
arch = x86_64
license = MIT
- makedepends = unzip
- makedepends = curl
+ makedepends = python-setuptools
makedepends = python-pip
- depends = python-pygame
- depends = python-pyperclip
- depends = python-rsa
- depends = python-numpy
depends = cython
- depends = tk
depends = python-dill
+ depends = python-numpy
+ depends = python-pygame>=1.9.4
+ depends = python-pyperclip
+ depends = python-rsa
+ source = injection-0.10.2.tar.bz2::https://gitlab.com/toastengineer/injection/-/archive/master/INJECTION-master.tar.bz2
source = injection.sh
source = injection.desktop
source = icon.png
- source = INJECTION_0.9.4_src.zip.md5
- md5sums = 5f21ca7a8891291e250f5296ba855324
- md5sums = cf419413f1dda3dcae7c665c9bb4bf46
- md5sums = 2e6543984ecc80ddf57ed822b344e0e1
- md5sums = 9c20daa901cc7f1230481dc45185649c
+ sha256sums = 4fd7c3cbf32d09283d956ca42e92f2ffb97633956288d54bf0c6f0163b9461d5
+ sha256sums = 93fbcd694536f0a9928bcd4c274c5436998c8b0f6b527e7729007bd7c30dc7fe
+ sha256sums = 149b1700eddf2c0aba61a7bc9756ea9a464826478e6bf94bf23ea320781991b1
+ sha256sums = 1b4deae94db1a44d5ff4db9399b5038fe17d5cd45454eaa00f3f4925a49337be
pkgname = injection
-
diff --git a/INJECTION_0.9.4_src.zip.md5 b/INJECTION_0.9.4_src.zip.md5
deleted file mode 100644
index d1c6fbb5db0c..000000000000
--- a/INJECTION_0.9.4_src.zip.md5
+++ /dev/null
@@ -1 +0,0 @@
-f0ffcb2126d6d410b11cc3991bfaa3bf INJECTION_0.9.4_src.zip
diff --git a/PKGBUILD b/PKGBUILD
index 63587801955e..1cc2279204f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,56 @@
-# Maintainer: pigt <pay2630 at gmail dot com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: pigt <pay2630 at gmail dot com>
+
pkgname=injection
-pkgver=0.9.4
+pkgver=0.10.2
pkgrel=1
-pkgdesc="A Python-based ASCII programming-puzzle game."
-arch=('i686' 'x86_64')
-url="https://schilcote.itch.io/injection"
+pkgdesc="Python-based ASCII programming-puzzle game"
+arch=('x86_64')
+url="https://toastengineer.itch.io/injection"
license=('MIT')
-depends=('python-pygame' 'python-pyperclip' 'python-rsa' 'python-numpy' 'cython' 'tk' 'python-dill')
-makedepends=('unzip' 'curl' 'python-pip' )
-source=(injection.sh injection.desktop icon.png INJECTION_${pkgver}_src.zip.md5)
-md5sums=('5f21ca7a8891291e250f5296ba855324'
- 'cf419413f1dda3dcae7c665c9bb4bf46'
- '2e6543984ecc80ddf57ed822b344e0e1'
- '9c20daa901cc7f1230481dc45185649c')
-
-_release_url="https://schilcote.itch.io/injection/file/309125?after_download_lightbox=true"
+depends=(
+ 'cython'
+ 'python-dill'
+ 'python-numpy'
+ 'python-pygame>=1.9.4'
+ 'python-pyperclip'
+ 'python-rsa')
+makedepends=('python-setuptools' 'python-pip')
+source=(
+ "$pkgname-$pkgver.tar.bz2::https://gitlab.com/toastengineer/injection/-/archive/master/INJECTION-master.tar.bz2"
+ injection.sh
+ injection.desktop
+ icon.png)
+sha256sums=('4fd7c3cbf32d09283d956ca42e92f2ffb97633956288d54bf0c6f0163b9461d5'
+ '93fbcd694536f0a9928bcd4c274c5436998c8b0f6b527e7729007bd7c30dc7fe'
+ '149b1700eddf2c0aba61a7bc9756ea9a464826478e6bf94bf23ea320781991b1'
+ '1b4deae94db1a44d5ff4db9399b5038fe17d5cd45454eaa00f3f4925a49337be')
prepare() {
- #Download url always changing to prevent hotlink. So we must deal with it.
- #url extraction code was copied from "after school"'s package.
- _dl_url=$(curl -s -XPOST "${_release_url}" | grep -Po '"url":.*?[^\\]",' | cut -c8- | rev |cut -c3- | rev | sed 's/\\\//\//g')
- echo "Downloading from $_dl_url"
- if [ ! -f INJECTION_${pkgver}_src.zip ]; then
- curl "$_dl_url" -o "INJECTION_${pkgver}_src.zip"
- fi
- md5sum -c INJECTION_${pkgver}_src.zip.md5
- unzip INJECTION_${pkgver}_src.zip -d "$pkgname-$pkgver"
- mv $pkgname-$pkgver/INJECTION\ $pkgver\ Python\ 3\ Source/* "$pkgname-$pkgver"
-
+ mv INJECTION-master "$pkgname-$pkgver"
}
-_python_depends=('pymsgbox' 'pygcurse')
build() {
cd "$pkgname-$pkgver"
#module that doesn't exist in repo.
- mkdir 'custom_packages'
+ local _python_depends=('pymsgbox' 'pygcurse' 'pyconsolegraphics' 'pyerrorreport')
+ mkdir -p 'custom_packages'
pip install -t 'custom_packages' ${_python_depends[*]}
export PYTHONPATH='./custom_packages'
#Build fx
python setup.py build_ext
cp build/lib*/* .
- rm -r build
+ rm -r build
}
package() {
- mkdir -p "$pkgdir/usr/lib"
- cp -r "$pkgname-$pkgver" "$pkgdir/usr/lib/injection" #Program and assets.
- install -D -m644 "$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/injection/LICENSE" #License.
- install -D -m755 "injection.sh" "$pkgdir/usr/lib/injection/injection.sh" #Launch script.
- mkdir "$pkgdir/usr/bin/"
+ install -d "$pkgdir/usr/lib" "$pkgdir/usr/bin/"
+ cp -a --no-preserve=ownership "$pkgname-$pkgver" "$pkgdir/usr/lib/injection" #Program and assets.
+ install -D -m644 "$pkgname-$pkgver/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -D -m755 "injection.sh" -t "$pkgdir/usr/lib/injection/"
ln -s "/usr/lib/injection/injection.sh" "$pkgdir/usr/bin/injection"
- install -D -m644 "injection.desktop" "$pkgdir/usr/share/applications/injection.desktop"
- install -D -m644 "icon.png" "$pkgdir/usr/lib/injection/icon.png"
+ install -D -m644 "injection.desktop" -t "$pkgdir/usr/share/applications/"
+ install -D -m644 "icon.png" -t "$pkgdir/usr/lib/injection/"
}
diff --git a/injection.desktop b/injection.desktop
index 114255c4c725..f884f1f4c481 100644
--- a/injection.desktop
+++ b/injection.desktop
@@ -8,5 +8,3 @@ Path=/usr/lib/injection
Exec=injection
Icon=/usr/lib/injection/icon.png
Terminal=false
-
-