summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b3bd643120e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = insync-nemo
+ pkgdesc = Nemo integration for insync
+ pkgver = 1.2.8.35316
+ pkgrel = 1
+ url = https://www.insynchq.com/downloads
+ arch = any
+ license = custom:insync
+ makedepends = gtk-doc
+ depends = insync
+ depends = nemo
+ depends = python2-nemo
+ noextract = insync-nemo-1.2.8.35316.deb
+ options = !strip
+ source = insync-nemo-1.2.8.35316.deb::http://s.insynchq.com/builds/insync-nemo_1.2.8.35316-precise_all.deb
+ sha256sums = 6d3223f6428190dfac1fe4966dbeae5af2fb7632bf0a1023d54be8d445df24d8
+
+pkgname = insync-nemo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..809624fc28fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Mark Weiman <mark dot weiman at markzz dot com>
+# Contributor: Zhengyu Xu <xzy3186@gmail.com>
+
+pkgname=insync-nemo
+pkgver=1.2.8.35316
+pkgrel=1
+pkgdesc="Nemo integration for insync"
+url="https://www.insynchq.com/downloads"
+license=('custom:insync')
+options=(!strip)
+arch=('any')
+
+depends=("insync" "nemo" "python2-nemo")
+makedepends=('gtk-doc')
+source=("${pkgname}-${pkgver}.deb::http://s.insynchq.com/builds/${pkgname}_${pkgver}-precise_all.deb")
+sha256sums=("6d3223f6428190dfac1fe4966dbeae5af2fb7632bf0a1023d54be8d445df24d8")
+noextract=("${pkgname}-${pkgver}.deb")
+
+package() {
+ cd $srcdir
+ ar x ${pkgname}-${pkgver}.deb
+ tar xvf data.tar.gz
+ cp -rp usr $pkgdir
+}