summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60f50cf32489..8c66d67174d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: IP2Location <support@ip2location.com>
-pkgname=ip2loaction-io-cli
+pkgname=ip2location-io-cli
_pkgname=${pkgname%}
pkgver=1.1.0
pkgrel=1
@@ -13,7 +13,7 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/ip2location/ip2location-io-
sha256sums=('86caf3202b8daea3a58aa3be3caa8514312116fba659d8e9e212e37b651b9f0d')
prepare() {
- cd "cli-${_pkgname}-$pkgver"
+ cd "${_pkgname}-$pkgver"
export GOPATH="$srcdir/gopath"
# download dependencies
@@ -21,20 +21,20 @@ prepare() {
}
build() {
- cd "cli-${_pkgname}-$pkgver"
+ cd "${_pkgname}-$pkgver"
export GOPATH="$srcdir/gopath"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- go build -v -o build "./${_pkgname}"
+ go build -v -o build ./ip2locationio
# Clean module cache for makepkg -C
go clean -modcache
}
package() {
- cd "cli-${_pkgname}-$pkgver"
- install -Dm755 "build/${_pkgname}" -t "$pkgdir/usr/bin/"
+ cd "${_pkgname}-$pkgver"
+ install -Dm755 "build/ip2locationio" -t "$pkgdir/usr/bin/"
} \ No newline at end of file