summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 441080d21445..3c3b558a0423 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Feb 6 00:22:38 UTC 2017
pkgbase = ipmiview
pkgdesc = Supermicro IPMI tool
- pkgver = 2.10.2
+ pkgver = 2.12.0
pkgrel = 1
url = http://www.supermicro.com/products/nfo/ipmi.cfm
arch = x86_64
- arch = i686
license = custom:"Super Micro Computer"
makedepends = tar
depends = glibc
depends = java-runtime=8
- source = ftp://ftp.supermicro.com/utility/IPMIView/Linux/ipmiview_V2.10.2_bundleJRE_Linux_x32_20150203.tar.gz
+ source = ftp://ftp.supermicro.com/utility/IPMIView/Linux/IPMIView_2.12.0_build.160804_bundleJRE_Linux_x64.tar.gz
source = ipmiview.desktop
- sha256sums = 577ccc48e7d70325ef2f922a0784acdcf72fe6bded8e195a47efa03da6db4b74
- sha256sums = 42a428fb0466ff1e925f712f1f4daa69a5b1d3b3f9cd4728b0da19646a39a427
+ sha256sums = 787a060413451a4a5993c31805f55a221087b7199bbaf20e9fe1254e2a76db42
+ sha256sums = 41d5fa089912ee10d476a0f6aa3c12765861c1a71cf4f811efaf2e47c4ce9351
pkgname = ipmiview
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b3ffc61d25f6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.gz
+/*.xz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
index f1d357a7cb55..4e68d9418419 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,25 @@
# Maintainer: Roberto Valentini <valantin89[at]gmail[dot]com>
pkgname=ipmiview
-pkgver=2.11.0
+pkgver=2.12.0
_pkgname=IPMIView
-_pkgrev=20151223
-_pkgver=${_pkgver}_${_pkgrev}
+_pkgrev=160804
pkgrel=1
pkgdesc="Supermicro IPMI tool"
makedepends=('tar')
depends=("glibc" "java-runtime=8")
-arch=('x86_64' 'i686')
-if [ "${CARCH}" = "x86_64" ]; then
- _pkgarch=x64
-else
- _pkgarch=x32
-fi
+arch=('x86_64')
license=('custom:"Super Micro Computer"')
url="http://www.supermicro.com/products/nfo/ipmi.cfm"
-source=("ftp://ftp.supermicro.com/utility/IPMIView/Linux/${_pkgname}_V${pkgver}_bundleJRE_Linux_${_pkgarch}_${_pkgrev}.tar.gz"
+source=("ftp://ftp.supermicro.com/utility/IPMIView/Linux/${_pkgname}_${pkgver}_build.${_pkgrev}_bundleJRE_Linux_x64.tar.gz"
"ipmiview.desktop")
-sha256sums=('41040c92a5a345a349b71949255e2744be509bbb0b185b44bd51c4d3229069e7'
+
+sha256sums=('787a060413451a4a5993c31805f55a221087b7199bbaf20e9fe1254e2a76db42'
'41d5fa089912ee10d476a0f6aa3c12765861c1a71cf4f811efaf2e47c4ce9351')
package() {
- cd ${srcdir}/${_pkgname}_V${pkgver}_bundleJRE_Linux_${_pkgarch}_${_pkgrev}
+ # IPMIView_2.12.0_build.160804_bundleJRE_Linux_x64
+ cd ${srcdir}/${_pkgname}_${pkgver}_build.${_pkgrev}_bundleJRE_Linux_x64
mkdir -p ${pkgdir}/opt/${pkgname}
mkdir -p ${pkgdir}/usr/bin