summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eaf5c12f8707..ac17459ccf5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,11 +12,9 @@ depends=('linux' 'iptables')
makedepends=('git' 'libtool' 'gcc' 'gzip' 'gawk' 'sed')
source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
-# define 'lts' for linux-lts package
-_linux_custom="ARCH"
# define '-lts' for linux-lts package
-_linux_localversion=""
-_kernver="`pacman -Ql linux${_linux_localversion} | awk '/(\/modules\/)([0-9.-])+-(.*)-'${_linux_custom}'\/$/ {print $2}'`"
+_linux_custom=""
+_kernver="`pacman -Ql linux${_linux_custom} | awk '/(\/modules\/)([0-9.-])+-(.*)'${_linux_custom}'\/$/ {print $2}' | head -n1`"
pkgver() {
cd "${srcdir}/${pkgname}"