summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
-rw-r--r--ibootpatcher.sh7
-rw-r--r--ipwndfu.sh7
-rw-r--r--ipwnrecovery.sh7
5 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bedb1268126
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ipwndfu-linushenze-git
+ pkgdesc = Open-source jailbreaking tool for many iOS devices
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/LinusHenze/ipwndfu_public
+ arch = x86_64
+ license = GPL3
+ makedepends = python2
+ source = git+https://github.com/LinusHenze/ipwndfu_public.git
+ source = ipwndfu.sh
+ source = ipwnrecovery.sh
+ source = ibootpatcher.sh
+ sha512sums = SKIP
+ sha512sums = fc3cadfd5b8b04cb411f3d30e86f7db731a0521ad114dabacbcc0e1d883145b93e39645ae3e50db5c1ffeb773d71f4c41b6fa3098317ca3dc3b0be03e2049ef0
+ sha512sums = 9589ceb40fcf43f7922d20500c6851e5e59c91c7ae8cea7d45b4acbf8368f9397666da3394ecac3f9ad955889a820fd3ce6911a646288ee936cf6b94c13a188d
+ sha512sums = 2eedf2828955f56ed7534e8fe24b47160fc2ea5a62dffbda1c4180859b1689b074a740deea1d8ea62d05ba8043ccc5e4bd9d2bd772882cfb056e0e52dd54980a
+
+pkgname = ipwndfu-linushenze-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33c9edfa6fd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=ipwndfu-linushenze-git
+pkgver=1
+pkgrel=1
+pkgdesc="Open-source jailbreaking tool for many iOS devices"
+arch=('x86_64')
+url="https://github.com/LinusHenze/ipwndfu_public"
+license=('GPL3')
+makedepends=('python2')
+source=("git+https://github.com/LinusHenze/ipwndfu_public.git"
+ "ipwndfu.sh"
+ "ipwnrecovery.sh"
+ "ibootpatcher.sh")
+sha512sums=('SKIP'
+ 'fc3cadfd5b8b04cb411f3d30e86f7db731a0521ad114dabacbcc0e1d883145b93e39645ae3e50db5c1ffeb773d71f4c41b6fa3098317ca3dc3b0be03e2049ef0'
+ '9589ceb40fcf43f7922d20500c6851e5e59c91c7ae8cea7d45b4acbf8368f9397666da3394ecac3f9ad955889a820fd3ce6911a646288ee936cf6b94c13a188d'
+ '2eedf2828955f56ed7534e8fe24b47160fc2ea5a62dffbda1c4180859b1689b074a740deea1d8ea62d05ba8043ccc5e4bd9d2bd772882cfb056e0e52dd54980a')
+
+package() {
+ mkdir -p "${pkgdir}/usr/lib"
+ cp -r "${srcdir}/ipwndfu_public" "${pkgdir}/usr/lib/ipwndfu"
+ install -Dm 755 "${srcdir}/ipwnrecovery.sh" "${pkgdir}/usr/bin/ipwnrecovery"
+ install -Dm 755 "${srcdir}/ipwndfu.sh" "${pkgdir}/usr/bin/ipwndfu"
+ install -Dm 755 "${srcdir}/ibootpatcher.sh" "${pkgdir}/usr/bin/ibootpatcher"
+}
diff --git a/ibootpatcher.sh b/ibootpatcher.sh
new file mode 100644
index 000000000000..fef291a65908
--- /dev/null
+++ b/ibootpatcher.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+cd /usr/lib/ipwndfu
+python2 ibootpatcher "$@"
+
+# vim: ts=2 sw=2 et:
+
diff --git a/ipwndfu.sh b/ipwndfu.sh
new file mode 100644
index 000000000000..3e5c11bcffa3
--- /dev/null
+++ b/ipwndfu.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+cd /usr/lib/ipwndfu
+python2 ipwndfu "$@"
+
+# vim: ts=2 sw=2 et:
+
diff --git a/ipwnrecovery.sh b/ipwnrecovery.sh
new file mode 100644
index 000000000000..19d61939b6d8
--- /dev/null
+++ b/ipwnrecovery.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+cd /usr/lib/ipwndfu
+python2 ipwnrecovery "$@"
+
+# vim: ts=2 sw=2 et:
+