summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d50b490e277..1eddf30c7bec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = ir-lv2
- pkgdesc = Real-time signal convolver especially suited for creating reverb effects
+ pkgdesc = LV2 Impulse response (convolution) plugin (for reverb and cabinet simulation)
pkgver = 1.3.2
pkgrel = 1
- url = http://factorial.hu/plugins/lv2/ir
+ url = https://github.com/Anchakor/ir.lv2
arch = i686
arch = x86_64
groups = lv2-plugins
license = GPL
makedepends = lv2
+ makedepends = git
depends = zita-convolver
depends = libsamplerate
depends = gtk2>=2.16
@@ -16,8 +17,8 @@ pkgbase = ir-lv2
conflicts = lv2-ir
conflicts = lv2-ir-git
conflicts = ir.lv2
- source = http://factorial.hu/system/files/ir.lv2-1.3.2.tar.gz
- sha256sums = ef9053e7b6002ed9f0b9a95046ec61cfb7035c0b2159f0fdc98ad44403f802ca
+ source = ir-lv2::git+https://github.com/Anchakor/ir.lv2#commit=af1f8ab
+ sha256sums = SKIP
pkgname = ir-lv2
diff --git a/PKGBUILD b/PKGBUILD
index 8c5a3007c241..8091f4f17777 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,26 @@
pkgname=ir-lv2
pkgver=1.3.2
pkgrel=1
-pkgdesc='Real-time signal convolver especially suited for creating reverb effects'
+pkgdesc='LV2 Impulse response (convolution) plugin (for reverb and cabinet simulation)'
arch=('i686' 'x86_64')
-url='http://factorial.hu/plugins/lv2/ir'
+url='https://github.com/Anchakor/ir.lv2'
license=('GPL')
depends=('zita-convolver' 'libsamplerate' 'gtk2>=2.16')
provides=('ir-lv2')
conflicts=('ir-lv2-git' 'lv2-ir' 'lv2-ir-git' 'ir.lv2')
groups=('lv2-plugins')
-makedepends=('lv2')
-source=("http://factorial.hu/system/files/${pkgname/-/.}-${pkgver}.tar.gz")
-sha256sums=('ef9053e7b6002ed9f0b9a95046ec61cfb7035c0b2159f0fdc98ad44403f802ca')
+makedepends=('lv2' 'git')
+source=("$pkgname::git+https://github.com/Anchakor/ir.lv2#commit=af1f8ab")
+sha256sums=('SKIP')
build() {
- cd "${pkgname/-/.}-${pkgver}"
+ cd "${pkgname}"
make
make convert4chan
}
package() {
- cd "${pkgname/-/.}-${pkgver}"
+ cd "${pkgname}"
make PREFIX="$pkgdir/usr" install
install -Dm755 convert4chan "$pkgdir/usr/bin/convert4chan"
install -Dm644 README "${pkgdir}"/usr/share/doc/$pkgname/README