summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7b0044228c3..7fe67db939c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,8 @@ pkgbase = iris-flower-wayland
arch = x86_64
license = GPL3
depends = ddccontrol
- source = https://github.com/ueberchild/iris-flower-wayland/blob/master/iris-flower-wayland.c
+ source = git+https://github.com/ueberchild/iris-flower-wayland.git
+ md5sums = SKIP
pkgname = iris-flower-wayland
diff --git a/PKGBUILD b/PKGBUILD
index 76e9c88b93c3..3278839fd729 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,15 @@ arch=('i686' 'x86_64')
url="https://github.com/ueberchild/iris-flower-wayland"
license=('GPL3')
depends=('ddccontrol')
-source=("https://github.com/ueberchild/iris-flower-wayland/blob/master/iris-flower-wayland.c")
+source=("git+https://github.com/ueberchild/iris-flower-wayland.git")
+md5sums=('SKIP')
build() {
- cd "$srcdir/"
+ cd "${srcdir}/$pkgname/"
cc -Wall -std=c99 -o iris-flower-wayland iris-flower-wayland.c
}
package() {
- cd "$srcdir/"
- install -D iris-flower-wayland "$pkgdir/usr/bin/iris-flower-wayland"
+ cd "${srcdir}/$pkgname/"
+ install -D iris-flower-wayland "$pkgdir/usr/bin/iris-flower-wayland"
}