summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD3
-rw-r--r--isolate.install4
2 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5bb10cdf36a6..5649ac29387b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ ISOLATE_GID=29267
pkgname=isolate
pkgver=r58.e8894c4
-pkgrel=2
+pkgrel=1
pkgdesc="Sandbox for securely executing untrusted programs"
arch=('any')
url="https://github.com/ioi/isolate"
@@ -39,6 +39,5 @@ build() {
}
package() {
- mkdir -p $pkgdir/usr/bin
install -D -m4750 -g$ISOLATE_GID $pkgname/isolate $pkgdir/usr/bin/isolate
}
diff --git a/isolate.install b/isolate.install
index b9c5ae0f9f05..ed79d5767e5b 100644
--- a/isolate.install
+++ b/isolate.install
@@ -17,6 +17,10 @@ post_install() {
fi
}
+post_upgrade() {
+ post_install $1
+}
+
post_remove() {
groupdel isolate
}