summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD50
2 files changed, 39 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 979ab424b8c5..fa1b2c37b3b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = j4-dmenu-desktop-git
pkgdesc = A rewrite of i3-dmenu-desktop, which is much faster
- pkgver = 2.18.r11.g7a64862
- pkgrel = 4
+ pkgver = 2.18.r231.g7da7e1d
+ pkgrel = 2
url = https://github.com/enkore/j4-dmenu-desktop
arch = i686
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
makedepends = git
- makedepends = cmake
+ makedepends = meson
+ depends = fmt
+ depends = spdlog
optdepends = dmenu: the default backend
optdepends = bemenu: an alternative backend
provides = j4-dmenu-desktop
conflicts = j4-dmenu-desktop
- source = git+https://github.com/enkore/j4-dmenu-desktop.git
- md5sums = SKIP
+ source = j4-dmenu-desktop-git::git+https://github.com/enkore/j4-dmenu-desktop.git
+ b2sums = SKIP
pkgname = j4-dmenu-desktop-git
diff --git a/PKGBUILD b/PKGBUILD
index b62504329c2a..ff3711332ec4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,50 @@
-# Maintainer: mrdotx <klassiker@gmx.de>
+# Maintainer: Nicola Revelant <nicolarevelant@outlook.com>
+# Contributor: mrdotx <klassiker@gmx.de>
# Contributor: shulhan <ms@kilabit.info>
# Contributor: Bill Kolokithas <kolokithas.b@gmail.com>
+
_pkgname=j4-dmenu-desktop
pkgname=j4-dmenu-desktop-git
-pkgver=2.18.r11.g7a64862
-pkgrel=4
+pkgver=2.18.r231.g7da7e1d
+pkgrel=2
pkgdesc='A rewrite of i3-dmenu-desktop, which is much faster'
arch=('i686' 'x86_64')
url='https://github.com/enkore/j4-dmenu-desktop'
-license=('GPL3')
+license=('GPL-3.0-only')
+depends=(
+ 'fmt'
+ 'spdlog'
+)
makedepends=(
- 'git'
- 'cmake')
+ 'git'
+ 'meson'
+)
optdepends=(
- 'dmenu: the default backend'
- 'bemenu: an alternative backend'
+ 'dmenu: the default backend'
+ 'bemenu: an alternative backend'
)
-provides=('j4-dmenu-desktop')
-conflicts=('j4-dmenu-desktop')
-source=('git+https://github.com/enkore/j4-dmenu-desktop.git')
-md5sums=('SKIP')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$pkgname::git+https://github.com/enkore/j4-dmenu-desktop.git")
+b2sums=('SKIP')
pkgver() {
- cd "$_pkgname"
- git describe --long | sed -r 's/^r//;s/([^-]*-g)/r\1/;s/-/./g'
+ cd "$pkgname"
+ git describe --long | sed -r 's/^r//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$pkgname"
+ meson subprojects download
}
build() {
- cd "$_pkgname"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DNO_TESTS=1 .
- make
+ cd "$pkgname"
+ arch-meson build
+ meson compile -C build
}
package() {
- cd "$_pkgname"
- make DESTDIR="$pkgdir"/ install
+ cd "$pkgname"
+ meson install -C build --destdir "$pkgdir"
}