summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD14
2 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abacd0354eeb..d35292d0a010 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = java-16-openjdk
pkgver = 16.0.2.u7
- pkgrel = 1
+ pkgrel = 2
url = https://openjdk.java.net/
arch = x86_64
license = custom
@@ -58,7 +58,7 @@ pkgname = jre16-openjdk-headless
optdepends = java-rhino: for some JavaScript support
provides = java-runtime-headless=16
provides = java-runtime-headless-openjdk=16
- provides = jre16-openjdk-headless=16.0.2.u7-1
+ provides = jre16-openjdk-headless=16.0.2.u7-2
backup = etc/java-16-openjdk/logging.properties
backup = etc/java-16-openjdk/management/jmxremote.access
backup = etc/java-16-openjdk/management/jmxremote.password.template
@@ -77,7 +77,7 @@ pkgname = jre16-openjdk-headless
pkgname = jre16-openjdk
pkgdesc = OpenJDK Java 16 full runtime environment
install = install_jre-openjdk.sh
- depends = jre16-openjdk-headless=16.0.2.u7-1
+ depends = jre16-openjdk-headless=16.0.2.u7-2
depends = giflib
depends = libgif.so
depends = glibc
@@ -88,12 +88,12 @@ pkgname = jre16-openjdk
optdepends = gtk3: for the Gtk+ 3 look and feel - desktop usage
provides = java-runtime=16
provides = java-runtime-openjdk=16
- provides = jre16-openjdk=16.0.2.u7-1
+ provides = jre16-openjdk=16.0.2.u7-2
pkgname = jdk16-openjdk
pkgdesc = OpenJDK Java 16 development kit
install = install_jdk-openjdk.sh
- depends = jre16-openjdk=16.0.2.u7-1
+ depends = jre16-openjdk=16.0.2.u7-2
depends = java-environment-common=3
depends = hicolor-icon-theme
depends = libelf
@@ -102,14 +102,14 @@ pkgname = jdk16-openjdk
provides = java-environment=16
provides = java-environment-jdk=16
provides = java-environment-openjdk=16
- provides = jdk16-openjdk=16.0.2.u7-1
+ provides = jdk16-openjdk=16.0.2.u7-2
pkgname = openjdk16-src
pkgdesc = OpenJDK Java 16 sources
- depends = jdk16-openjdk=16.0.2.u7-1
- provides = openjdk16-src=16.0.2.u7-1
+ depends = jdk16-openjdk=16.0.2.u7-2
+ provides = openjdk16-src=16.0.2.u7-2
pkgname = openjdk16-doc
pkgdesc = OpenJDK Java 16 documentation
- depends = jdk16-openjdk=16.0.2.u7-1
- provides = openjdk16-doc=16.0.2.u7-1
+ depends = jdk16-openjdk=16.0.2.u7-2
+ provides = openjdk16-doc=16.0.2.u7-2
diff --git a/PKGBUILD b/PKGBUILD
index d6b8e51a0633..f70e0d5c1619 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _majorver=16
_minorver=0
_securityver=2
_updatever=7
-pkgrel=1
+pkgrel=2
pkgver="${_majorver}.${_minorver}.${_securityver}.u${_updatever}"
_git_tag="jdk-${_majorver}.${_minorver}.${_securityver}+${_updatever}"
arch=('x86_64')
@@ -44,8 +44,8 @@ _nonheadless=(lib/libawt_xawt.{so,debuginfo}
lib/libsplashscreen.{so,debuginfo})
prepare() {
- # Avoid the use of any Java 8-14, actually incompatible with the build
- export JAVA_HOME="/usr/lib/jvm/$(archlinux-java status | tail -n +2 | sort | cut -d ' ' -f 3 | sort -nr -k 2 -t '-' | grep -vE '8-|9-|10-|11-|12-|13-|14-' -m 1)"
+ # Use only Java versions 15-16
+ export JAVA_HOME="/usr/lib/jvm/$(archlinux-java status | tail -n +2 | sort | cut -d ' ' -f 3 | sort -nr -k 2 -t '-' | grep -E '15-|16-' -m 1)"
}
build() {
@@ -70,6 +70,14 @@ build() {
_CXXFLAGS="${CXXFLAGS/-fno-plt/}"
fi
+ # TODO: Should be rechecked for the next releases
+ # compiling with -fexceptions leads to:
+ # /usr/bin/ld: /build/java-openjdk/src/jdk17u-jdk-17.0.3-2/build/linux-x86_64-server-release/hotspot/variant-server/libjvm/objs/zPhysicalMemory.o: in function `ZList<ZMemory>::~ZList()':
+ # /build/java-openjdk/src/jdk17u-jdk-17.0.3-2/src/hotspot/share/gc/z/zList.hpp:54: undefined reference to `ZListNode<ZMemory>::~ZListNode()'
+ # collect2: error: ld returned 1 exit status
+ _CFLAGS=${CFLAGS/-fexceptions/}
+ _CXXFLAGS=${CXXFLAGS/-fexceptions/}
+
# CFLAGS, CXXFLAGS and LDFLAGS are ignored as shown by a warning
# in the output of ./configure unless used like such:
# --with-extra-cflags="${CFLAGS}"