summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--0001-make-logger-static-again.patch65
-rw-r--r--PKGBUILD31
3 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..668bcfe49d57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = java-inetlib
+ pkgdesc = GNU Java library of clients for common internet protocols
+ pkgver = 1.1.2
+ pkgrel = 4
+ url = https://www.gnu.org/software/classpath/inetlib.html
+ arch = any
+ license = GPL
+ makedepends = java-environment
+ depends = java-runtime-headless
+ source = https://ftp.gnu.org/gnu/classpath/inetlib-1.1.2.tar.gz
+ source = 0001-make-logger-static-again.patch
+ md5sums = e28147996e70b63b6caa743319a4bf46
+ md5sums = 9f231445d1f3307fb601f48d8ce25f7f
+
+pkgname = java-inetlib
+
diff --git a/0001-make-logger-static-again.patch b/0001-make-logger-static-again.patch
new file mode 100644
index 000000000000..f37a74f5c4cf
--- /dev/null
+++ b/0001-make-logger-static-again.patch
@@ -0,0 +1,65 @@
+From: Torsten Werner <twerner@debian.org>
+Date: Sun, 25 Sep 2011 18:36:30 +0200
+Subject: make logger static again
+
+Revert some changes in upstream version 1.1.2 that breaks other packages.
+---
+ source/gnu/inet/imap/IMAPConnection.java | 2 +-
+ source/gnu/inet/nntp/NNTPConnection.java | 2 +-
+ source/gnu/inet/pop3/POP3Connection.java | 2 +-
+ source/gnu/inet/smtp/SMTPConnection.java | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/source/gnu/inet/imap/IMAPConnection.java b/source/gnu/inet/imap/IMAPConnection.java
+index 039644a..42745db 100644
+--- a/source/gnu/inet/imap/IMAPConnection.java
++++ b/source/gnu/inet/imap/IMAPConnection.java
+@@ -120,7 +120,7 @@ public class IMAPConnection
+ /**
+ * The logger used for IMAP protocol traces.
+ */
+- public final Logger logger = Logger.getLogger("gnu.inet.imap");
++ public static final Logger logger = Logger.getLogger("gnu.inet.imap");
+
+ /**
+ * The socket used for communication with the server.
+diff --git a/source/gnu/inet/nntp/NNTPConnection.java b/source/gnu/inet/nntp/NNTPConnection.java
+index 26898d6..172a5cf 100644
+--- a/source/gnu/inet/nntp/NNTPConnection.java
++++ b/source/gnu/inet/nntp/NNTPConnection.java
+@@ -105,7 +105,7 @@ public class NNTPConnection
+ /**
+ * The logger used for NNTP protocol traces.
+ */
+- public final Logger logger = Logger.getLogger("gnu.inet.nntp");
++ public static final Logger logger = Logger.getLogger("gnu.inet.nntp");
+
+ /**
+ * The hostname of the host we are connected to.
+diff --git a/source/gnu/inet/pop3/POP3Connection.java b/source/gnu/inet/pop3/POP3Connection.java
+index 3bdaa48..859083c 100644
+--- a/source/gnu/inet/pop3/POP3Connection.java
++++ b/source/gnu/inet/pop3/POP3Connection.java
+@@ -136,7 +136,7 @@ public class POP3Connection
+ /**
+ * The logger used for POP3 protocol traces.
+ */
+- public final Logger logger = Logger.getLogger("gnu.inet.pop3");
++ public static final Logger logger = Logger.getLogger("gnu.inet.pop3");
+
+ /**
+ * The socket used to communicate with the server.
+diff --git a/source/gnu/inet/smtp/SMTPConnection.java b/source/gnu/inet/smtp/SMTPConnection.java
+index c625f28..f97262d 100644
+--- a/source/gnu/inet/smtp/SMTPConnection.java
++++ b/source/gnu/inet/smtp/SMTPConnection.java
+@@ -124,7 +124,7 @@ public class SMTPConnection
+ /**
+ * The logger used for SMTP protocol traces.
+ */
+- public final Logger logger = Logger.getLogger("gnu.inet.smtp");
++ public static final Logger logger = Logger.getLogger("gnu.inet.smtp");
+
+ /**
+ * The underlying socket used for communicating with the server.
+--
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cda2d61fdcff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Guillaume ALAUX <guillaume@archlinux.org>
+_libname=inetlib
+pkgname=java-${_libname}
+pkgver=1.1.2
+pkgrel=4
+pkgdesc="GNU Java library of clients for common internet protocols"
+arch=('any')
+url="https://www.gnu.org/software/classpath/inetlib.html"
+license=('GPL')
+depends=('java-runtime-headless')
+makedepends=('java-environment')
+source=(https://ftp.gnu.org/gnu/classpath/${_libname}-${pkgver}.tar.gz
+ 0001-make-logger-static-again.patch)
+md5sums=('e28147996e70b63b6caa743319a4bf46'
+ '9f231445d1f3307fb601f48d8ce25f7f')
+
+build() {
+ cd ${_libname}-${pkgver}
+
+ patch -p1 < "${srcdir}"/0001-make-logger-static-again.patch
+
+ ./configure
+ make
+}
+
+package() {
+ install -Dm644 ${_libname}-${pkgver}/${_libname}.jar \
+ "${pkgdir}"/usr/share/java/${_libname}-${pkgver}.jar
+
+ ln -s ${_libname}-${pkgver}.jar "${pkgdir}"/usr/share/java/${_libname}.jar
+}