summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--jdiamonds.desktop10
-rw-r--r--jdiamonds_icon.pngbin0 -> 3557 bytes
4 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23a3b08a5370
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = jdiamonds
+ pkgdesc = JDiamonds is a jewel like game written in Java
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://games.os.vc
+ arch = any
+ license = GPLv3
+ depends = java-runtime
+ source = https://games.os.vc/jgames/jdiamonds-1.0/jdiamonds.jar
+ source = jdiamonds_icon.png
+ source = jdiamonds.desktop
+ md5sums = 7d19dc1d292cd71cb7026968894a6f7b
+ md5sums = 7dbe50a3a109e19c8cca9c6e524cce56
+ md5sums = decae5c71961a5bf911e7b283fae0866
+
+pkgname = jdiamonds
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..faffc1d972e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: -=De/\/=-
+pkgname=jdiamonds
+pkgver=1.0
+pkgrel=1
+pkgdesc="JDiamonds is a jewel like game written in Java"
+arch=('any')
+url='https://games.os.vc'
+license=('GPLv3')
+
+depends=('java-runtime')
+
+source=('https://games.os.vc/jgames/jdiamonds-1.0/jdiamonds.jar'
+ 'jdiamonds_icon.png'
+ 'jdiamonds.desktop')
+
+package() {
+ cd ${srcdir}
+ install -d -m755 ${pkgdir}/usr/local/games/jdiamonds
+ install -D -m644 jdiamonds_icon.png ${pkgdir}/usr/share/pixmaps/jdiamonds_icon.png
+ install -D -m644 jdiamonds.desktop ${pkgdir}/usr/share/applications/jdiamonds.desktop
+ install -D -m644 jdiamonds.jar ${pkgdir}/usr/local/games/jdiamonds/jdiamonds.jar
+}
+
+md5sums=('7d19dc1d292cd71cb7026968894a6f7b'
+ '7dbe50a3a109e19c8cca9c6e524cce56'
+ 'decae5c71961a5bf911e7b283fae0866')
diff --git a/jdiamonds.desktop b/jdiamonds.desktop
new file mode 100644
index 000000000000..6844b9846c89
--- /dev/null
+++ b/jdiamonds.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Exec=java -jar /usr/local/games/jdiamonds/jdiamonds.jar
+Icon=/usr/share/pixmaps/jdiamonds_icon.png
+Name=JDiamonds
+Terminal=false
+Type=Application
+Categories=GNOME;GTK;Game;
+Encoding=UTF-8
+Comment=JDiamonds - jewel like game written in java
+
diff --git a/jdiamonds_icon.png b/jdiamonds_icon.png
new file mode 100644
index 000000000000..0bbd5f47ea06
--- /dev/null
+++ b/jdiamonds_icon.png
Binary files differ