summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD19
-rw-r--r--freedesktop-java.desktop6
-rw-r--r--freedesktop-jconsole.desktop6
-rw-r--r--freedesktop-jshell.desktop6
-rw-r--r--install_jdk-temurin.sh2
6 files changed, 36 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 278922f9b704..b493541dc62a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jdk-temurin
- pkgdesc = Temurin (OpenJDK 21 Java binaries by Adoptium, formerly AdoptOpenJDK)
- pkgver = 21.0.2.u13
+ pkgdesc = Temurin (OpenJDK 22 Java binaries by Adoptium, formerly AdoptOpenJDK)
+ pkgver = 22.0.0.u36
pkgrel = 1
url = https://adoptium.net/
install = install_jdk-temurin.sh
@@ -15,18 +15,16 @@ pkgbase = jdk-temurin
depends = alsa-lib
optdepends = gtk2: for the Gtk+ 2 look and feel
optdepends = gtk3: for the Gtk+ 3 look and feel
- provides = java-runtime-headless=21
- provides = java-runtime-headless-openjdk=21
- provides = jre21-openjdk-headless=21.0.2.u13
- provides = java-runtime=21
- provides = java-runtime-openjdk=21
- provides = jre21-openjdk=21.0.2.u13
- provides = java-environment=21
- provides = java-environment-openjdk=21
- provides = jdk21-openjdk=21.0.2.u13
- provides = jdk-openjdk=21.0.2.u13
- provides = openjdk21-src=21.0.2.u13
- provides = openjdk-src=21.0.2.u13
+ provides = java-runtime-headless=22
+ provides = java-runtime-headless-openjdk=22
+ provides = java-runtime=22
+ provides = java-runtime-openjdk=22
+ provides = java-environment=22
+ provides = java-environment-openjdk=22
+ provides = jdk22-openjdk=22.0.0.u36
+ provides = jdk-openjdk=22.0.0.u36
+ provides = openjdk22-src=22.0.0.u36
+ provides = openjdk-src=22.0.0.u36
replaces = jdk-adoptopenjdk
options = !strip
backup = etc/java-temurin/logging.properties
@@ -44,13 +42,13 @@ pkgbase = jdk-temurin
backup = etc/java-temurin/security/policy/unlimited/default_local.policy
backup = etc/java-temurin/security/policy/unlimited/default_US_export.policy
backup = etc/java-temurin/sound.properties
- source = https://github.com/adoptium/temurin21-binaries/releases/download/jdk-21.0.2%2B13/OpenJDK21U-jdk_x64_linux_hotspot_21.0.2_13.tar.gz
+ source = https://github.com/adoptium/temurin22-binaries/releases/download/jdk-22%2B36/OpenJDK22U-jdk_x64_linux_hotspot_22_36.tar.gz
source = freedesktop-java.desktop
source = freedesktop-jconsole.desktop
source = freedesktop-jshell.desktop
- sha256sums = 454bebb2c9fe48d981341461ffb6bf1017c7b7c6e15c6b0c29b959194ba3aaa5
- sha256sums = 23ced5efdb3381e6318af1acb343c714b2d9aacdb4666fee05dc58cd254b2d07
- sha256sums = ef7f6465272608a35615665f8e4b0837b43b4db7bf22f8eb7cecdd6170b5b2ee
- sha256sums = 166b128e025404e7b4048c5b3c958e080a13a98f84b6faa9cfe11530f553e287
+ sha256sums = bc3d99e816d0c373f424cd7aa2b6d3e8081a7189fe55c1561616922200ec8e47
+ sha256sums = a67f393684e85d04653eb925fa4a6baaa618a152899bb81646a4ff7f30e84c30
+ sha256sums = bc6f506add26b48d77282535026357984fdb8bd924fe6f053fbec5a37984b710
+ sha256sums = 0544f1ca50c9d8d4a7361392c31e5cdafdd12e9587c9a1d710074f6ab14f7aff
pkgname = jdk-temurin
diff --git a/PKGBUILD b/PKGBUILD
index c365f9027220..2425fdedcc49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,13 @@
# This PKGBUILD is maintained on github:
# https://github.com/michaellass/AUR
-_majorver=21
-_completever=21.0.2
-_updatever=13
+_majorver=22
+_completever=22.0.0
+_updatever=36
pkgrel=1
pkgver=${_completever}.u${_updatever}
-_tag_ver=${_completever}+${_updatever}
+#_tag_ver=${_completever}+${_updatever}
+_tag_ver=${_majorver}+${_updatever}
_versuffix=U
pkgname=jdk-temurin
@@ -26,10 +27,8 @@ optdepends=('gtk2: for the Gtk+ 2 look and feel'
'gtk3: for the Gtk+ 3 look and feel')
provides=("java-runtime-headless=${_majorver}"
"java-runtime-headless-openjdk=${_majorver}"
- "jre${_majorver}-openjdk-headless=${pkgver}"
"java-runtime=${_majorver}"
"java-runtime-openjdk=${_majorver}"
- "jre${_majorver}-openjdk=${pkgver}"
"java-environment=${_majorver}"
"java-environment-openjdk=${_majorver}"
"jdk${_majorver}-openjdk=${pkgver}"
@@ -59,10 +58,10 @@ source=(https://github.com/adoptium/temurin${_majorver}-binaries/releases/downlo
freedesktop-java.desktop
freedesktop-jconsole.desktop
freedesktop-jshell.desktop)
-sha256sums=('454bebb2c9fe48d981341461ffb6bf1017c7b7c6e15c6b0c29b959194ba3aaa5'
- '23ced5efdb3381e6318af1acb343c714b2d9aacdb4666fee05dc58cd254b2d07'
- 'ef7f6465272608a35615665f8e4b0837b43b4db7bf22f8eb7cecdd6170b5b2ee'
- '166b128e025404e7b4048c5b3c958e080a13a98f84b6faa9cfe11530f553e287')
+sha256sums=('bc3d99e816d0c373f424cd7aa2b6d3e8081a7189fe55c1561616922200ec8e47'
+ 'a67f393684e85d04653eb925fa4a6baaa618a152899bb81646a4ff7f30e84c30'
+ 'bc6f506add26b48d77282535026357984fdb8bd924fe6f053fbec5a37984b710'
+ '0544f1ca50c9d8d4a7361392c31e5cdafdd12e9587c9a1d710074f6ab14f7aff')
_jvmdir=/usr/lib/jvm/java-${_majorver}-temurin
_jdkdir=jdk-${_tag_ver}
diff --git a/freedesktop-java.desktop b/freedesktop-java.desktop
index 7df5f0d5750f..103150316351 100644
--- a/freedesktop-java.desktop
+++ b/freedesktop-java.desktop
@@ -1,8 +1,8 @@
[Desktop Entry]
-Name=Temurin Java 21 Runtime
-Comment=Temurin Java 21 Runtime
+Name=Temurin Java 22 Runtime
+Comment=Temurin Java 22 Runtime
Keywords=java;runtime
-Exec=/usr/lib/jvm/java-21-temurin/bin/java -jar
+Exec=/usr/lib/jvm/java-22-temurin/bin/java -jar
Terminal=false
Type=Application
MimeType=application/x-java-archive;application/java-archive;application/x-jar;
diff --git a/freedesktop-jconsole.desktop b/freedesktop-jconsole.desktop
index 74fb22ca27cd..4e21f8de0d5c 100644
--- a/freedesktop-jconsole.desktop
+++ b/freedesktop-jconsole.desktop
@@ -1,8 +1,8 @@
[Desktop Entry]
-Name=Temurin Java 21 Console
-Comment=Temurin Java 21 Monitoring & Management Console
+Name=Temurin Java 22 Console
+Comment=Temurin Java 22 Monitoring & Management Console
Keywords=java;console;monitoring
-Exec=/usr/lib/jvm/java-21-temurin/bin/jconsole
+Exec=/usr/lib/jvm/java-22-temurin/bin/jconsole
Terminal=false
Type=Application
Categories=Application;System;
diff --git a/freedesktop-jshell.desktop b/freedesktop-jshell.desktop
index 6da68f5e9bc3..4a52bc447bce 100644
--- a/freedesktop-jshell.desktop
+++ b/freedesktop-jshell.desktop
@@ -1,8 +1,8 @@
[Desktop Entry]
-Name=Temurin Java 21 Shell
-Comment=Temurin Java 21 Shell
+Name=Temurin Java 22 Shell
+Comment=Temurin Java 22 Shell
Keywords=java;shell
-Exec=/usr/lib/jvm/java-21-temurin/bin/jshell
+Exec=/usr/lib/jvm/java-22-temurin/bin/jshell
Terminal=true
Type=Application
Categories=Application;System;
diff --git a/install_jdk-temurin.sh b/install_jdk-temurin.sh
index ebb7c528333a..cb105de1e226 100644
--- a/install_jdk-temurin.sh
+++ b/install_jdk-temurin.sh
@@ -1,4 +1,4 @@
-THIS_JDK='java-21-temurin'
+THIS_JDK='java-22-temurin'
fix_default() {
if [ ! -x /usr/bin/java ]; then