summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD50
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..083d03a6e6e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = jfa-go-git
+ pkgdesc = A web app for managing users on Jellyfin
+ pkgver = r71.e56a138
+ pkgrel = 1
+ url = https://github.com/hrfee/jfa-go
+ arch = x86_64
+ license = MIT
+ makedepends = go>=1.14
+ makedepends = python>=3.6.0-1
+ makedepends = nodejs
+ makedepends = npm
+ provides = jfa-go
+ conflicts = jfa-go
+ source = jfa-go-git::git+https://github.com/hrfee/jfa-go.git
+ md5sums = SKIP
+
+pkgname = jfa-go-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4cf277d8b8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Harvey Tindall <hrfee@protonmail.ch>
+pkgname=jfa-go-git
+_pkgname=jfa-go
+pkgver=r71.e56a138
+pkgrel=1
+pkgdesc="A web app for managing users on Jellyfin"
+arch=("x86_64")
+url="https://github.com/hrfee/jfa-go"
+license=('MIT')
+makedepends=('go>=1.14' 'python>=3.6.0-1' 'nodejs' 'npm')
+checkdepends=()
+optdepends=()
+provides=("jfa-go")
+conflicts=("jfa-go")
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}::git+https://github.com/hrfee/jfa-go.git")
+noextract=()
+md5sums=(SKIP)
+validpgpkeys=()
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+ make configuration sass-headless mail-headless version
+}
+
+build() {
+ cd ${pkgname}
+ make compile
+}
+
+package() {
+ cd ${pkgname}
+ make copy
+ install -d "$pkgdir"/opt
+ make install DESTDIR="$pkgdir"/opt
+ mkdir -p "$pkgdir"/usr/bin
+ chown -R root "$pkgdir"/opt/$_pkgname/
+ chmod 755 "$pkgdir"/opt/$_pkgname/$_pkgname
+ ln -sf /opt/$_pkgname/$_pkgname "$pkgdir"/usr/bin/$_pkgname
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$_pkgname
+}