summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7974de8660e2..02b85d6f2819 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
# Generated by mksrcinfo v8
-# Sun Mar 13 07:10:24 UTC 2016
+# Sat Nov 5 11:19:22 UTC 2016
pkgbase = jquery-ui
- pkgdesc = Build highly interactive web applications with low-level interaction and high-level widgets
- pkgver = 1.11.4
+ pkgdesc = A curated set of user interface interactions, effects, widgets, and themes built on top of the jQuery JavaScript Library.
+ pkgver = 1.12.1
pkgrel = 1
- url = http://jqueryui.com/
+ url = https://jqueryui.com/
arch = any
license = MIT
- makedepends = npm
- makedepends = nodejs-grunt-cli
depends = jquery
- source = https://github.com/jquery/jquery-ui/archive/1.11.4.tar.gz
- sha256sums = 5d6035c1d802667a4d1f56b4c7f40aff142ae46ed462de9dacb7687ad705a4c0
+ source = https://jqueryui.com/resources/download/jquery-ui-1.12.1.zip
+ md5sums = e0cfea21c9d1acd37fb58592f2c1f50d
pkgname = jquery-ui
diff --git a/PKGBUILD b/PKGBUILD
index f416f78e3f83..dfe096dd4de5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,23 @@
+#Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
#Maintainer: David McInnis <davidm@eagles.ewu.edu>
#Contributer: André Silva <emulatorman@parabola.nu>
#Contributer: Márcio Silva <coadde@parabola.nu>
-_pkgname=jquery
pkgname=jquery-ui
-pkgver=1.11.4
+pkgver=1.12.1
pkgrel=1
-pkgdesc='Build highly interactive web applications with low-level interaction and high-level widgets'
+pkgdesc='A curated set of user interface interactions, effects, widgets, and themes built on top of the jQuery JavaScript Library.'
arch=('any')
-url='http://jqueryui.com/'
+url='https://jqueryui.com/'
license=('MIT')
depends=('jquery')
-makedepends=('npm' 'nodejs-grunt-cli')
-
-source=("https://github.com/$_pkgname/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('5d6035c1d802667a4d1f56b4c7f40aff142ae46ed462de9dacb7687ad705a4c0')
-
-build() {
- cd $srcdir/$pkgname-$pkgver
- npm install
- grunt concat:ui uglify:main
-}
+source=("https://jqueryui.com/resources/download/$pkgname-$pkgver.zip")
+md5sums=('e0cfea21c9d1acd37fb58592f2c1f50d')
package() {
cd $srcdir/$pkgname-$pkgver
install -d $pkgdir/usr/share/javascript/$pkgname
install -d $pkgdir/usr/share/licenses/$pkgname
- cp -a dist/* $pkgdir/usr/share/javascript/$pkgname
+ cp -a ./${pkgname}*.{js,css} $pkgdir/usr/share/javascript/$pkgname/
cp -a LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
}