summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45566f24fbfe..6ef74fdf18a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = json_dto
pkgdesc = A small header-only library for converting data between json representation and c++ structs
pkgver = 0.3.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Stiffstream/json_dto
arch = any
- license = BSD
+ license = BSD-3-Clause
checkdepends = catch2-v2
makedepends = cmake
depends = rapidjson
diff --git a/PKGBUILD b/PKGBUILD
index 7331a15a7cb7..7e76ce179838 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Bert Peters <bert@bertptrs.nl>
pkgname=json_dto
pkgver=0.3.3
-pkgrel=1
+pkgrel=2
pkgdesc="A small header-only library for converting data between json representation and c++ structs"
arch=(any)
url="https://github.com/Stiffstream/json_dto"
-license=('BSD')
+license=('BSD-3-Clause')
depends=(rapidjson)
makedepends=(cmake)
checkdepends=(catch2-v2)
@@ -16,6 +16,7 @@ build() {
cd "$pkgname-v.$pkgver"
cmake dev -DCMAKE_INSTALL_PREFIX=/usr -DJSON_DTO_SAMPLE=Off \
-DJSON_DTO_TEST=On \
+ -DCMAKE_BUILD_TYPE=None \
-DJSON_DTO_FIND_DEPS=On -Wno-dev
make
}