summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD6
3 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff113c75d0f2..2225159cc859 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -21,7 +21,7 @@ pkgbase = julia-nightly-bin
source = 128x128.png::https://github.com/JuliaLang/julia/raw/master/contrib/mac/frameworkapp/JuliaLauncher/Assets.xcassets/AppIcon.appiconset/128.png
source = 256x256.png::https://github.com/JuliaLang/julia/raw/master/contrib/mac/frameworkapp/JuliaLauncher/Assets.xcassets/AppIcon.appiconset/256.png
source = 512x512.png::https://github.com/JuliaLang/julia/raw/master/contrib/mac/frameworkapp/JuliaLauncher/Assets.xcassets/AppIcon.appiconset/512.png
- sha256sums = 6c84d53c51d045f39535095bca1ed7ac513eea8cbe22e136d031b2cfdc9f60e4
+ sha256sums = SKIP
sha256sums = 85aff59221938dd83aa3808910fb455c64f3f0936604bfaad7b8d27c01e3a7ed
sha256sums = 0310782968fe0ba2910e8a4fc3920ab58c0b8f91c66a66f6cff82cd0d6d31612
sha256sums = aab27b427cb21108d831f2d9ddc89ce0948f7e8cb82e4bb2dc1bc82c6676224f
diff --git a/.gitignore b/.gitignore
index 960c204adbdb..801ce47502a9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
*.gz
+*.part
+*.zst
*.xz
pkg
src
-*.png \ No newline at end of file
+*.png
diff --git a/PKGBUILD b/PKGBUILD
index aafacbee22c9..efb31642b742 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ source=($pkgname-$pkgver.tar.gz::"https://julialangnightlies-s3.julialang.org/bi
128x128.png::https://github.com/JuliaLang/julia/raw/master/contrib/mac/frameworkapp/JuliaLauncher/Assets.xcassets/AppIcon.appiconset/128.png
256x256.png::https://github.com/JuliaLang/julia/raw/master/contrib/mac/frameworkapp/JuliaLauncher/Assets.xcassets/AppIcon.appiconset/256.png
512x512.png::https://github.com/JuliaLang/julia/raw/master/contrib/mac/frameworkapp/JuliaLauncher/Assets.xcassets/AppIcon.appiconset/512.png)
-sha256sums=('6c84d53c51d045f39535095bca1ed7ac513eea8cbe22e136d031b2cfdc9f60e4'
+sha256sums=('SKIP'
'85aff59221938dd83aa3808910fb455c64f3f0936604bfaad7b8d27c01e3a7ed'
'0310782968fe0ba2910e8a4fc3920ab58c0b8f91c66a66f6cff82cd0d6d31612'
'aab27b427cb21108d831f2d9ddc89ce0948f7e8cb82e4bb2dc1bc82c6676224f'
@@ -23,6 +23,10 @@ sha256sums=('6c84d53c51d045f39535095bca1ed7ac513eea8cbe22e136d031b2cfdc9f60e4'
'3994d4d59d46e2d226d59f372e5b68eb23e8dc074529e870796f1132f5df8a5b')
options=(!strip)
+pkgver() {
+ date +%Y%m%d
+}
+
package() {
hash=$(ls -ld $srcdir/* | grep -v tar | tail -n 1 | rev | cut -d '-' -f 1 | rev)
cd $srcdir/julia-${hash}