summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD33
-rw-r--r--jumpman.desktop10
-rw-r--r--jumpman.sh4
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1233d96309d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = jumpman
+ pkgdesc = An addictve retro-style game
+ pkgver = 1.0.2
+ pkgrel = 2
+ url = http://runhello.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = http://cat.runhello.com/Jumpman_lin.tar.gz
+ source = jumpman.sh
+ source = jumpman.desktop
+ sha256sums = f803df52902999b76b551b338ff61f7048787cdbada863ff4a8bf80ce212348c
+ sha256sums = 00453d83415cbebe45bd600b6be28bbe065a76721e179adb93c4824ba9689c6a
+ sha256sums = 934636c213556ab597d546a502b5a9c3c39998ed188b9c4efd583cf72af4217a
+ depends_i686 = freetype2
+ depends_i686 = glu
+ depends_i686 = libgl
+ depends_i686 = mesa
+ depends_i686 = pcre
+ depends_i686 = sdl
+ depends_i686 = libpulse
+ depends_x86_64 = lib32-freetype2
+ depends_x86_64 = lib32-glu
+ depends_x86_64 = lib32-libgl
+ depends_x86_64 = lib32-mesa
+ depends_x86_64 = lib32-pcre
+ depends_x86_64 = lib32-sdl
+ depends_x86_64 = lib32-libpulse
+ depends_x86_64 = lib32-alsa-plugins
+
+pkgname = jumpman
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d943ec22484f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+
+# TODO: needs a better icon
+
+set -u
+pkgname='jumpman'
+pkgver='1.0.2'
+pkgrel='2'
+pkgdesc='An addictve retro-style game'
+arch=('i686' 'x86_64')
+url='http://runhello.com/'
+license=('custom')
+depends_i686=('freetype2' 'glu' 'libgl' 'mesa' 'pcre' 'sdl' 'libpulse')
+depends_x86_64=("${depends_i686[@]/#/lib32-}" 'lib32-alsa-plugins')
+source=('http://cat.runhello.com/Jumpman_lin.tar.gz' "${pkgname}.sh" "${pkgname}.desktop")
+sha256sums=('f803df52902999b76b551b338ff61f7048787cdbada863ff4a8bf80ce212348c'
+ '00453d83415cbebe45bd600b6be28bbe065a76721e179adb93c4824ba9689c6a'
+ '934636c213556ab597d546a502b5a9c3c39998ed188b9c4efd583cf72af4217a')
+
+package() {
+ set -u
+ install -Dpm644 'Jumpman/Readme.txt' "${pkgdir}/usr/share/licenses/${pkgname}/Readme"
+ install -d "${pkgdir}/opt"
+ mv Jumpman "${pkgdir}/opt/${pkgname}"
+
+ install -Dpm755 "${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dpm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications/"
+ set +u
+}
+set +u
+
+# vim:set ts=2 sw=2 et:
diff --git a/jumpman.desktop b/jumpman.desktop
new file mode 100644
index 000000000000..2000edf2daf7
--- /dev/null
+++ b/jumpman.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Jumpman
+Comment=An addictive retro style game
+Exec=jumpman
+Terminal=false
+Type=Application
+StartupNotify=false
+Categories=GNOME;Game
+#Icon=
diff --git a/jumpman.sh b/jumpman.sh
new file mode 100644
index 000000000000..e82127ba5151
--- /dev/null
+++ b/jumpman.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+cd /opt/jumpman
+./Jumpman $@
+