summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
-rw-r--r--dischan_JunipersKnot.desktop2
-rwxr-xr-xjunipersknot4
4 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4e609206615..be7af93718dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,16 +5,16 @@ pkgbase = junipersknot
url = http://junipersknot.dischan.org/
arch = any
license = custom
- depends = renpy
+ depends = renpy python2-pygame
options = !strip
source = JunipersKnot_en_1.0_lin.tar.bz2::https://dischan.co/downloads/JunipersKnot_en_1.0_lin.tar.bz2
source = dischan_JunipersKnot.desktop
source = junipersknot
source = junipersknot.png
md5sums = 3318de6e4c5952271961d757bdd5fddf
- md5sums = 672677a075b4ed04f4a3ca71f6c33808
- md5sums = 6b294591761f99d780a8e4d64848aba2
- md5sums = SKIP
+ md5sums = dec96343fbf164e5e9d6c1b29f31b519
+ md5sums = 8d6decca098b103db2c3d6709a7a6332
+ md5sums = c3fd43e5bacc7f9ebbda0971a3e5b2d0
pkgname = junipersknot
diff --git a/PKGBUILD b/PKGBUILD
index 1fce4e130491..5f16341e6c7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,32 +8,26 @@ pkgdesc="A short kinetic novel crafted in a month by Dischan, Juniper's Knot is
arch=('any')
url="http://junipersknot.dischan.org/"
license=('custom')
-depends=('renpy')
+depends=('renpy python2-pygame')
options=(!strip)
source=("JunipersKnot_en_1.0_lin.tar.bz2::https://dischan.co/downloads/JunipersKnot_en_1.0_lin.tar.bz2"
dischan_JunipersKnot.desktop
junipersknot
junipersknot.png)
md5sums=('3318de6e4c5952271961d757bdd5fddf'
- '672677a075b4ed04f4a3ca71f6c33808'
- '6b294591761f99d780a8e4d64848aba2'
- 'SKIP')
-
-build() {
- cd "$srcdir/Juniper's Knot-linux-x86"
-}
+ 'dec96343fbf164e5e9d6c1b29f31b519'
+ '8d6decca098b103db2c3d6709a7a6332'
+ 'c3fd43e5bacc7f9ebbda0971a3e5b2d0')
package() {
cd "$srcdir/Juniper's Knot-linux-x86"
install -d "$pkgdir/usr/share/doc/$pkgname"
install -m644 README.txt SOUNDCREDITS.txt "$pkgdir/usr/share/doc/$pkgname/"
- install -Dm755 "$srcdir"/${pkgname} "$pkgdir/usr/bin/${pkgname}"
- install -Dm644 "Juniper's Knot.py" "$pkgdir/usr/share/$pkgname/Juniper's Knot.py"
install -Dm644 DISCHANLICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/DISCHANLICENSE.txt"
+ cd ..
+ mv "Juniper's Knot-linux-x86" "$pkgdir/usr/share/$pkgname"
+ mkdir "$pkgdir/usr/bin"
+ install -Dm755 "$srcdir/junipersknot" "$pkgdir/usr/bin/junipersknot"
install -Dm644 "$srcdir/junipersknot.png" "$pkgdir/usr/share/pixmaps/junipersknot.png"
install -Dm644 "$srcdir/dischan_JunipersKnot.desktop" "$pkgdir/usr/share/applications/dischan_JunipersKnot.desktop"
- mv game "$pkgdir/usr/share/$pkgname"
- mv lib "$pkgdir/usr/share/$pkgname"
- mv common "$pkgdir/usr/share/$pkgname"
- mv renpy "$pkgdir/usr/share/$pkgname"
}
diff --git a/dischan_JunipersKnot.desktop b/dischan_JunipersKnot.desktop
index dc7e80e5cc6f..f6ebc48c80fd 100644
--- a/dischan_JunipersKnot.desktop
+++ b/dischan_JunipersKnot.desktop
@@ -4,6 +4,6 @@ Version=1
Name=Juniper's Knot
Comment=A short kinetic novel crafted in a month by Dischan, Juniper's Knot is a story told from dual perspectives: that of a demon and a boy.
Icon=junipersknot
-Exec=/usr/bin/junipersknot
+Exec="/usr/share/Juniper's Knot.sh"
Terminal=false
Categories=Application;Game;
diff --git a/junipersknot b/junipersknot
index c8f73af8859f..f8ebbc6cbc5f 100755
--- a/junipersknot
+++ b/junipersknot
@@ -1,2 +1,4 @@
#!/bin/sh
-exec env RENPY_BASE=${RENPY_BASE:-/usr/share/renpy/} python2 -OO "/usr/share/junipersknot/Juniper's Knot.py" /usr/share/junipersknot "$@"
+cd /usr/share/junipersknot
+exec "./Juniper's Knot.sh"
+