summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD30
2 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30d4eae28a11..0a52afc53322 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = jupyter-octave_kernel
pkgdesc = A Jupyter kernel for Octave
- pkgver = 0.35.1
+ pkgver = 0.36.0
pkgrel = 1
url = https://github.com/Calysto/octave_kernel
arch = any
- license = BSD
+ license = BSD-3-Clause
makedepends = python-build
makedepends = python-hatchling
makedepends = python-installer
@@ -14,7 +14,7 @@ pkgbase = jupyter-octave_kernel
depends = python-jupyter_client
optdepends = gnuplot: for making plots
optdepends = jupyterlab: JupyterLab computational environment
- source = jupyter-octave_kernel-0.35.1.tar.gz::https://github.com/Calysto/octave_kernel/archive/v0.35.1.tar.gz
- b2sums = 62700070fbad51cd3b27823ef1e6d2b5b0c563b4234a1318fb886e1473b3b0874a319ece85c7f31516ac95f5216858badbe7449ab6a24b337fa503e16f1c64ac
+ source = jupyter-octave_kernel-0.36.0.tar.gz::https://github.com/Calysto/octave_kernel/archive/v0.36.0.tar.gz
+ b2sums = be770836a40ad084b0ac80f9a00333916c071d653bfb628fd0de43c04abba695733081afed1b1545e465c67d9eca1303148300dc2091c5658337568aa00a0152
pkgname = jupyter-octave_kernel
diff --git a/PKGBUILD b/PKGBUILD
index b67fb7a0c5d3..f33fafd3e155 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,37 @@
# Contributor: renyuneyun <renyuneyun (at) gmail (dot) com>
_name=octave_kernel
pkgname=jupyter-${_name}
-pkgver=0.35.1
+pkgver=0.36.0
pkgrel=1
pkgdesc="A Jupyter kernel for Octave"
-arch=('any')
+arch=(any)
url="https://github.com/Calysto/octave_kernel"
-license=('BSD')
+license=(BSD-3-Clause)
depends=(
- 'jupyter-metakernel'
- 'octave'
- 'python-ipykernel'
- 'python-jupyter_client'
+ jupyter-metakernel
+ octave
+ python-ipykernel
+ python-jupyter_client
)
makedepends=(
- 'python-build'
- 'python-hatchling'
- 'python-installer'
+ python-build
+ python-hatchling
+ python-installer
)
optdepends=(
'gnuplot: for making plots'
'jupyterlab: JupyterLab computational environment'
)
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Calysto/octave_kernel/archive/v${pkgver}.tar.gz")
-b2sums=('62700070fbad51cd3b27823ef1e6d2b5b0c563b4234a1318fb886e1473b3b0874a319ece85c7f31516ac95f5216858badbe7449ab6a24b337fa503e16f1c64ac')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/Calysto/octave_kernel/archive/v${pkgver}.tar.gz)
+b2sums=('be770836a40ad084b0ac80f9a00333916c071d653bfb628fd0de43c04abba695733081afed1b1545e465c67d9eca1303148300dc2091c5658337568aa00a0152')
build() {
- cd "$srcdir"/$_name-${pkgver}
+ cd $_name-$pkgver
python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir"/$_name-${pkgver}
+ cd $_name-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
- install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}