summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78ec04aa17e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = kangaru
+ pkgdesc = An inversion of control container for C++11, C++14 and later
+ pkgver = 4.2.4+12+g4852a2e
+ pkgrel = 1
+ url = https://github.com/gracicot/kangaru
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ source = git+https://github.com/gracicot/kangaru.git
+ sha512sums = SKIP
+
+pkgname = kangaru
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d52c2d7b969c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Sebastian Frohn
+
+pkgname=('kangaru' )
+pkgver=4.2.4+12+g4852a2e
+pkgrel=1
+pkgdesc="An inversion of control container for C++11, C++14 and later"
+arch=('x86_64')
+url="https://github.com/gracicot/$pkgname"
+license=('MIT')
+depends=()
+makedepends=('git' 'cmake' )
+source=("git+$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed -r 's/^[r|v]//;s/-/+/g'
+}
+
+build() {
+ cd "$pkgname"
+
+ mkdir -p build && cd build
+
+ cmake ..
+}
+
+
+package() {
+ cd "$srcdir/$pkgname/build"
+
+ make DESTDIR=$pkgdir install
+}