summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD4
-rwxr-xr-xinstall.sh4
3 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85c18412c5bf..e6616268c135 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = karaokemugen
pkgdesc = Karaoke playlist manager/player app used in parties or events.
pkgver = 7.1.66
- pkgrel = 2
+ pkgrel = 3
url = https://mugen.karaokes.moe/
install = karaokemugen.install
arch = x86_64
@@ -29,7 +29,7 @@ pkgbase = karaokemugen
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = 74e8c0755a6e07cceb2895cef518660b
+ md5sums = 2548b70d012d3992526c8d5b1d9bac3d
md5sums = 31d8f86f4b4420ef9c83c1af31a45424
md5sums = 5e9a33a42fef7572b7e0fa504c586f32
md5sums = fae5d3e631e9ec8391655b31f586b74b
diff --git a/PKGBUILD b/PKGBUILD
index fd75577044db..964b38d9d0fa 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: leonekmi <usingarchbtw@leonekmi.fr>
pkgname=karaokemugen
pkgver=7.1.66
-pkgrel=2
+pkgrel=3
pkgdesc="Karaoke playlist manager/player app used in parties or events."
arch=('x86_64')
url="https://mugen.karaokes.moe/"
@@ -27,7 +27,7 @@ noextract=()
md5sums=('SKIP'
'SKIP'
'SKIP'
- '74e8c0755a6e07cceb2895cef518660b'
+ '2548b70d012d3992526c8d5b1d9bac3d'
'31d8f86f4b4420ef9c83c1af31a45424'
'5e9a33a42fef7572b7e0fa504c586f32'
'fae5d3e631e9ec8391655b31f586b74b')
diff --git a/install.sh b/install.sh
index 369425821232..25a354b182c5 100755
--- a/install.sh
+++ b/install.sh
@@ -42,8 +42,10 @@ setup_postgres() {
fi
# Creating the database
sudo -u postgres -g postgres -H -- psql -c "CREATE DATABASE karaokemugen_app ENCODING 'UTF8';"
- sudo -u postgres -g postgres -H -- psql -c "CREATE USER karaokemugen_app WITH ENCRYPTED PASSWORD 'musubi'; GRANT ALL PRIVILEGES ON DATABASE karaokemugen_app TO karaokemugen_app;"
+ sudo -u postgres -g postgres -H -- psql -c "CREATE USER karaokemugen_app WITH ENCRYPTED PASSWORD 'musubi';"
+ sudo -u postgres -g postgres -H -- psql -c "GRANT ALL PRIVILEGES ON DATABASE karaokemugen_app TO karaokemugen_app;"
sudo -u postgres -g postgres -H -- psql -d karaokemugen_app -c "CREATE EXTENSION unaccent;"
+ sudo -u postgres -g postgres -H -- psql -d karaokemugen_app -c "GRANT CREATE ON SCHEMA public TO public;"
echo -e "${_COL_GREEN_}karaokemugen_app database created!"
}