summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
-rw-r--r--keyd.sysusers1
3 files changed, 21 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f08f0f41d14..0ae866860820 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = keyd-git
- pkgdesc = A key remapping daemon for linux.
- pkgver = 2.4.3.r33.07a993d
+ pkgdesc = A key remapping daemon for linux
+ pkgver = 2.4.3.r46.5832c75
pkgrel = 1
url = https://github.com/rvaiya/keyd
arch = x86_64
arch = aarch64
license = MIT
makedepends = git
- optdepends = python3: for keyd-application-mapper
+ optdepends = python: Required for use with keyd-application-mapper utility
provides = keyd
conflicts = keyd
source = git+https://github.com/rvaiya/keyd.git
+ source = keyd.sysusers
sha256sums = SKIP
+ sha256sums = b3fa546c31f61be824a84a33af5c723692e2cedd4e5f87ff655e90f33227395d
pkgname = keyd-git
diff --git a/PKGBUILD b/PKGBUILD
index 6a3176bcdea7..aa428527d121 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,25 @@
# Maintainer: eNV25 <env252525@gmail.com>
+# Contributor: Brett Cornwall <ainola@archlinux.org>
pkgname=keyd-git
-pkgver=2.4.3.r33.07a993d
+pkgver=2.4.3.r46.5832c75
pkgrel=1
arch=('x86_64' 'aarch64')
-pkgdesc="A key remapping daemon for linux. "
+pkgdesc="A key remapping daemon for linux"
url="https://github.com/rvaiya/keyd"
license=('MIT')
makedepends=(git)
optdepends=(
- 'python3: for keyd-application-mapper'
+ "python: Required for use with keyd-application-mapper utility"
)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/rvaiya/keyd.git')
-sha256sums=('SKIP')
+source=(
+ 'git+https://github.com/rvaiya/keyd.git'
+ keyd.sysusers
+)
+sha256sums=('SKIP'
+ 'b3fa546c31f61be824a84a33af5c723692e2cedd4e5f87ff655e90f33227395d')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -27,17 +32,13 @@ pkgver() {
build() {
cd "$srcdir/${pkgname%-git}"
- make DESTDIR="${pkgdir}" PREFIX='/usr'
+ make DESTDIR="$pkgdir" PREFIX='/usr'
}
package() {
cd "$srcdir/${pkgname%-git}"
-
- # opt-in for systemd service and libinput quirks
- install -dm755 "${pkgdir}/usr/lib/systemd/system"
- install -dm755 "${pkgdir}/usr/share/libinput"
-
- make DESTDIR="${pkgdir}" PREFIX='/usr' install
- echo 'g keyd' | install -Dm644 /dev/stdin "${pkgdir}/usr/lib/sysusers.d/${pkgname%-git}.conf"
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname%-git}/"
+ make DESTDIR="$pkgdir" PREFIX='/usr' install
+ install -Dm644 ../keyd.sysusers "$pkgdir/usr/lib/sysusers.d/keyd.conf"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/keyd"
+ install -Dm644 keyd.service -t "$pkgdir/usr/lib/systemd/system/"
}
diff --git a/keyd.sysusers b/keyd.sysusers
new file mode 100644
index 000000000000..6dd468970bc2
--- /dev/null
+++ b/keyd.sysusers
@@ -0,0 +1 @@
+g keyd