summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--Fix-Doxygen-command-error.patch12
-rw-r--r--PKGBUILD26
-rw-r--r--kim-api.install3
4 files changed, 20 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53a342dae0e3..114cd027532f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kim-api
pkgdesc = Online framework for reliable, reproducible and portable molecular simulations
- pkgver = 2.1.0
+ pkgver = 2.2.1
pkgrel = 1
url = https://openkim.org
install = kim-api.install
@@ -8,12 +8,11 @@ pkgbase = kim-api
arch = x86_64
license = CDDL
makedepends = cmake
- makedepends = gcc-libs
- depends = bash
- source = https://s3.openkim.org/kim-api/kim-api-2.1.0.txz
- source = Fix-Doxygen-command-error.patch
- sha512sums = f49535f24ad64eb53b6e7f891040694cde04cae7d183290d5ab969f8ea440932d2edad1b41d3c2672de40b152b9b1d43301879dab2e12815eac6e9dfeba54238
- sha512sums = 0063cb18884a19d15261e910cc9877ff319f9c1b428023d736e34b5271f254a7eaca9b90033f80af560199e1fe363523da6afb4ee35a05af76b2760039a94cbd
+ makedepends = gcc-fortran
+ depends = xxd
+ optdepends = doxygen: build OpenKIM documentation
+ source = https://s3.openkim.org/kim-api/kim-api-2.2.1.txz
+ sha512sums = b2625dc41474849f281f266a1fa8a2b1738d2433031d2181bde36ac5ec050fcdec3925cb588b287a46c80c01c730be04352ca88a9ba71fc3b37c2da1c84ae650
pkgname = kim-api
diff --git a/Fix-Doxygen-command-error.patch b/Fix-Doxygen-command-error.patch
deleted file mode 100644
index f5b99748d558..000000000000
--- a/Fix-Doxygen-command-error.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e328925d..5da8fcda 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -43,6 +43,7 @@ include(DefaultCompilerStandards)
-
- # Define options
- #
-+set(DOXYGEN_LATEX_MAKEINDEX_CMD makeindex)
- set(KIM_API_PROJECT_NAME "kim-api" CACHE STRING "KIM API project name string")
- mark_as_advanced(KIM_API_PROJECT_NAME)
- #
diff --git a/PKGBUILD b/PKGBUILD
index 66f27cdeb675..e987884f8429 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,19 @@
# Maintainer: Daniel Schopf <schopf.dan at gmail dot com>
pkgname=kim-api
-pkgver=2.1.0
+pkgver=2.2.1
pkgrel=1
pkgdesc="Online framework for reliable, reproducible and portable molecular simulations"
arch=("i686" "x86_64")
url="https://openkim.org"
license=('CDDL')
-depends=(bash)
-makedepends=(cmake gcc-libs)
+depends=(xxd)
+optdepends=('doxygen: build OpenKIM documentation')
+makedepends=(cmake gcc-fortran)
install=$pkgname.install
-source=(https://s3.openkim.org/kim-api/kim-api-2.1.0.txz
- Fix-Doxygen-command-error.patch)
-sha512sums=('f49535f24ad64eb53b6e7f891040694cde04cae7d183290d5ab969f8ea440932d2edad1b41d3c2672de40b152b9b1d43301879dab2e12815eac6e9dfeba54238'
- '0063cb18884a19d15261e910cc9877ff319f9c1b428023d736e34b5271f254a7eaca9b90033f80af560199e1fe363523da6afb4ee35a05af76b2760039a94cbd')
+source=(https://s3.openkim.org/kim-api/kim-api-${pkgver}.txz)
+sha512sums=('b2625dc41474849f281f266a1fa8a2b1738d2433031d2181bde36ac5ec050fcdec3925cb588b287a46c80c01c730be04352ca88a9ba71fc3b37c2da1c84ae650')
prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 -i ../Fix-Doxygen-command-error.patch
- cd ..
mkdir -p build
}
@@ -28,6 +24,8 @@ build() {
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
-DCMAKE_INSTALL_LIBEXECDIR="/usr/lib" \
+ -DBASH_COMPLETION_COMPLETIONSDIR="/usr/share/bash-completion/completions" \
+ -DZSH_COMPLETION_COMPLETIONSDIR="/usr/share/zsh/site-functions" \
-DKIM_API_BUILD_EXAMPLES=ON
make
}
@@ -35,8 +33,8 @@ build() {
package() {
cd build
make DESTDIR="$pkgdir" install
-
- # remove empty directories
- cd "$pkgdir"
- rm -rf usr/share
+ cd "$pkgdir"/usr/share/emacs/site-lisp
+ mv kim-api/*.el .
+ rmdir kim-api
+ cd ../../..
}
diff --git a/kim-api.install b/kim-api.install
index a56a2d356ef9..77ad56a09fb3 100644
--- a/kim-api.install
+++ b/kim-api.install
@@ -14,7 +14,8 @@ yellow="${bold}$(tput setaf 3)"
post_install() {
note "KIM API has been installed with some example models."
- note "More models can be installed using the 'kim-api-collections-management' utility"
+ note "Additional models can be installed using the 'kim-api-collections-management' utility."
+ note "(All) models from OpenKIM.org are available in the openkim-models package."
}
post_upgrade() {