summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db57496ebfbd..461f578eee97 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kimtoy-frameworks-git
pkgdesc = Standalone input method panel. KF5 branch.
- pkgver = 1.10.1
+ pkgver = 20150824.ga4464f6
pkgrel = 1
url = http://kde-apps.org/content/show.php/KIMToy?content=140967
install = kimtoy-frameworks-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 7e3b2a5dd6ef..14439e268fbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: maz-1 <ohmygod19993 at gmail dot com>
pkgname=kimtoy-frameworks-git
-pkgver=1.10.1
+pkgver=20150824.ga4464f6
pkgdesc="Standalone input method panel. KF5 branch."
pkgrel=1
arch=('i686' 'x86_64')
@@ -18,6 +18,12 @@ conflicts=kimtoy
install=$pkgname.install
source=("git+https://github.com/ahyangyi/kimtoy.git#branch=kf5")
+pkgver() {
+ cd "$srcdir/kimtoy"
+ echo "$(git show -s --format="%ci"|grep -oP '\d{4}-\d{2}-\d{2}'|sed 's:-::g').g$(git describe --always)"
+}
+
+
prepare() {
rm -rf build
mkdir -p build