summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
-rw-r--r--klatexformula.install13
-rw-r--r--klfbackend.patch11
4 files changed, 29 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03b174e3b439..5819f513405c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,19 +2,18 @@ pkgbase = klatexformula
pkgdesc = Provides GUI for generating images from LaTeX equations
pkgver = 4.1.0
pkgrel = 1
- url = http://klatexformula.sourceforge.net
- install = klatexformula.install
- arch = i686
+ url = https://klatexformula.sourceforge.io/
arch = x86_64
license = GPL2
+ makedepends = cmake
+ makedepends = qt5-tools
+ makedepends = qt5-x11extras
+ depends = ghostscript
depends = python
- depends = qt5-base
- depends = qt5-tools
depends = qt5-svg
- source = http://sourceforge.net/projects/klatexformula/files/klatexformula/klatexformula-4.1.0/klatexformula-4.1.0.tar.gz
- source = klfbackend.patch
- md5sums = 6c17a3f3f415221bf6630cec2cd7485d
- md5sums = c4549b8d521b97010d1dc99ba5265fec
+ depends = texlive-core
+ source = https://downloads.sourceforge.net/klatexformula/klatexformula-4.1.0.tar.gz
+ sha256sums = 7af0999eeee38176ea34f9f96b358e43e343c73edf6f56143f18794303ca8702
pkgname = klatexformula
diff --git a/PKGBUILD b/PKGBUILD
index ba78119ce07f..49aef75aed00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,29 @@
# Maintainer: Allen Choong <allen.choong at gmail dot com>
+
pkgname=klatexformula
pkgver=4.1.0
pkgrel=1
pkgdesc="Provides GUI for generating images from LaTeX equations"
-url='http://klatexformula.sourceforge.net'
-arch=('i686' 'x86_64')
-license=('GPL2')
-depends=('python' 'qt5-base' 'qt5-tools' 'qt5-svg')
-source=("http://sourceforge.net/projects/klatexformula/files/klatexformula/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz" "klfbackend.patch")
-md5sums=('6c17a3f3f415221bf6630cec2cd7485d'
- 'c4549b8d521b97010d1dc99ba5265fec')
-install="${pkgname}.install"
+arch=(x86_64)
+url='https://klatexformula.sourceforge.io/'
+license=(GPL2)
+depends=(ghostscript python qt5-svg texlive-core)
+makedepends=(cmake qt5-tools qt5-x11extras)
+source=(https://downloads.sourceforge.net/klatexformula/$pkgname-$pkgver.tar.gz)
+sha256sums=('7af0999eeee38176ea34f9f96b358e43e343c73edf6f56143f18794303ca8702')
+
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i "41i#include <QPainterPath>" src/klftools/klfflowlistwidget_p.h
+}
+
+build() {
+ cd $pkgname-$pkgver
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}/"
- sed -i "s|(uninstall|(uninstall2|" cmake/klfinstallpaths.cmake
- sed -i "30i#include <QAction>" src/klftools/klfadvancedconfigeditor.cpp
- sed -i "41i#include <QPainterPath>" src/klftools/klfflowlistwidget_p.h
- patch -p1 -u < ../klfbackend.patch
- mkdir build && cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib ..
- make DESTDIR="${pkgdir}/" install
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
}
diff --git a/klatexformula.install b/klatexformula.install
deleted file mode 100644
index 66189adc2e24..000000000000
--- a/klatexformula.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- update-mime-database usr/share/mime
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
- update-desktop-database -q
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}
diff --git a/klfbackend.patch b/klfbackend.patch
deleted file mode 100644
index b82f8ad5ab26..000000000000
--- a/klfbackend.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/klfbackend/klfbackend.cpp 2017-03-06 09:53:20.615968858 +0800
-+++ b/src/klfbackend/klfbackend.cpp 2017-03-06 08:58:48.620180000 +0800
-@@ -193,7 +193,7 @@
- // if v is just ascii, no need to encode it in unicode
- bool isascii = true;
- for (i = 0; i < v.length(); ++i) {
-- if (v[i] < 0 || v[i] > 126) {
-+ if (v[i].unicode() < 0 || v[i].unicode() > 126) {
- isascii = false;
- break;
- }