summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD37
-rw-r--r--visual-studio-code.desktop8
-rw-r--r--visual-studio-code.pngbin0 -> 46528 bytes
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a868ca34fe5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = visual-studio-code
+ pkgdesc = Editor for building and debugging modern web and cloud applications
+ pkgver = 0.1.0
+ pkgrel = 2
+ url = https://code.visualstudio.com/
+ arch = x86_64
+ license = custom: commercial
+ depends = fontconfig
+ depends = libxtst
+ depends = gtk2
+ depends = python
+ depends = cairo
+ depends = alsa-lib
+ depends = gconf
+ depends = nss
+ depends = gcc-libs
+ provides = vscode,visualstudiocode
+ source = http://download.microsoft.com/download/0/D/5/0D57186C-834B-463A-AECB-BC55A8E466AE/VSCode-linux-x64.zip
+ source = visual-studio-code.png
+ source = visual-studio-code.desktop
+ md5sums = 50d4547e3617ace370f040edace6d7cd
+ md5sums = 6dfffd3ebb0f173f5cd13b432fcdb2db
+ md5sums = 94c9ab66cc24c2683873e07b2a5aada4
+
+pkgname = visual-studio-code
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1664894357d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: D. Can Celasun <dcelasun[at]gmail[dot]com>
+
+pkgname=visual-studio-code
+pkgver=0.1.0
+pkgrel=2
+pkgdesc="Editor for building and debugging modern web and cloud applications"
+arch=('x86_64')
+url="https://code.visualstudio.com/"
+license=('custom: commercial')
+provides=('vscode','visualstudiocode')
+depends=(fontconfig libxtst gtk2 python cairo alsa-lib gconf nss gcc-libs)
+source=(http://download.microsoft.com/download/0/D/5/0D57186C-834B-463A-AECB-BC55A8E466AE/VSCode-linux-x64.zip
+ ${pkgname}.png
+ ${pkgname}.desktop
+ )
+md5sums=('50d4547e3617ace370f040edace6d7cd'
+ '6dfffd3ebb0f173f5cd13b432fcdb2db'
+ '94c9ab66cc24c2683873e07b2a5aada4')
+
+package() {
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d "${pkgdir}/opt/${pkgname}"
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/share/icons"
+
+ install -m644 "${srcdir}/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/icons/${pkgname}.png"
+ install -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ rm -f "${srcdir}"/${pkgname}.png
+ rm -f "${srcdir}"/${pkgname}.desktop
+ rm -f "${srcdir}"/VSCode-linux-x64.zip
+
+ cp -r "${srcdir}/"* "${pkgdir}/opt/${pkgname}" -R
+ ln -s /opt/${pkgname}/Code "${pkgdir}"/usr/bin/visual-studio-code
+}
diff --git a/visual-studio-code.desktop b/visual-studio-code.desktop
new file mode 100644
index 000000000000..8acb6b5eb88c
--- /dev/null
+++ b/visual-studio-code.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Categories=Development;
+Exec=/usr/bin/visual-studio-code
+Icon=visual-studio-code
+Terminal=false
+Type=Application
+Name=Visual Studio Code
+Comment=Editor for building and debugging modern web and cloud applications
diff --git a/visual-studio-code.png b/visual-studio-code.png
new file mode 100644
index 000000000000..11ec4ee7e7e5
--- /dev/null
+++ b/visual-studio-code.png
Binary files differ