summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD59
2 files changed, 46 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba088035eef9..3374c8766e6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = kompare-git
pkgdesc = Graphical file differences tool
- pkgver = 23.08.3.r41.gac940ef
+ pkgver = 24.02.2.r81.g848439e
pkgrel = 1
url = https://invent.kde.org/sdk/kompare
arch = x86_64
- license = GPL
- license = LGPL
- license = FDL
+ license = GPL-2.0-or-later
+ license = LGPL-2.0-or-later
+ makedepends = cmake
makedepends = extra-cmake-modules
makedepends = git
- makedepends = kdoctools5
- depends = hicolor-icon-theme
- depends = ktexteditor5
- depends = libkomparediff2
- provides = kompare=23.08.3
+ makedepends = kdoctools
+ makedepends = ninja
+ depends = libkomparediff2-git
+ depends = ktexteditor
+ provides = kompare=24.02.2
conflicts = kompare
- source = kompare::git+https://invent.kde.org/sdk/kompare.git
+ source = kompare::git+https://invent.kde.org/sdk/kompare.git#branch=kf6
sha256sums = SKIP
pkgname = kompare-git
diff --git a/PKGBUILD b/PKGBUILD
index 2fb6d900fb37..645d2081f419 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,69 @@
-# Maintainer: Sándor Nagy <sanya868 at gmail dot com>
-# Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer:
+# Contributor: Sándor Nagy <sanya868 at gmail dot com>
+## options
+: ${_branch:=kf6}
+
+# basic info
_pkgname="kompare"
pkgname="$_pkgname-git"
-pkgver=23.08.3.r41.gac940ef
+pkgver=24.02.2.r81.g848439e
pkgrel=1
pkgdesc="Graphical file differences tool"
url="https://invent.kde.org/sdk/kompare"
-license=('GPL' 'LGPL' 'FDL')
+license=('GPL-2.0-or-later' 'LGPL-2.0-or-later')
arch=('x86_64')
depends=(
- 'hicolor-icon-theme'
- 'ktexteditor5'
- 'libkomparediff2'
+ 'libkomparediff2-git'
+ 'ktexteditor'
+
+ ## implicit
+ #hicolor-icon-theme
+ #kcodecs
+ #kcompletion
+ #kconfig
+ #kconfigwidgets
+ #kcoreaddons
+ #ki18n
+ #kio
+ #kparts
+ #kwidgetsaddons
+ #kxmlgui
+ #qt6-base
)
makedepends=(
+ 'cmake'
'extra-cmake-modules'
'git'
- 'kdoctools5'
+ 'kdoctools'
+ 'ninja'
)
provides=("$_pkgname=${pkgver%%.r*}")
conflicts=("$_pkgname")
_pkgsrc="$_pkgname"
-source=("$_pkgsrc"::"git+$url.git")
+source=("$_pkgsrc"::"git+https://invent.kde.org/sdk/kompare.git#branch=${_branch:-master}")
sha256sums=('SKIP')
pkgver() {
cd "$_pkgsrc"
- local _tag=$(git tag | grep -Ev '\.[0-9][0-9]$' | sort -V | tail -1)
- local _revision=$(git rev-list --count $_tag..HEAD)
- local _hash=$(git rev-parse --short HEAD)
-
- printf '%s.r%s.g%s' \
- "${_tag#v}" \
- "$_revision" \
- "$_hash"
-}
-
-_prepare() {
- mkdir -p build
+ local _tag=$(git tag | grep -Ev '\.[0-9][0-9]$' | sort -rV | head -1)
+ local _revision=$(git rev-list --cherry-pick --count "$_tag"...HEAD)
+ local _hash=$(git rev-parse --short=7 HEAD)
- #sed 's|${DATA_INSTALL_DIR}|${KXMLGUI_INSTALL_DIR}|g' -i kompare{,/komparepart}/CMakeLists.txt
+ printf '%s.r%s.g%s' "${_tag#v}" "$_revision" "$_hash"
}
build() {
local _cmake_options=(
-B build
-S "$_pkgsrc"
+ -G Ninja
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ -DBUILD_WITH_QT6=ON
-DBUILD_TESTING=OFF
-Wno-dev
)
@@ -60,5 +73,5 @@ build() {
}
package() {
- DESTDIR="${pkgdir:?}" cmake --install build
+ DESTDIR="$pkgdir" cmake --install build
}