summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe743940873b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = kongdash-bin
+ pkgdesc = ORY Hydra is a hardened, certified OAuth2 and OpenID Connect server optimized for low-latency, high throughput, and low resource consumption.
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://ajaysreedhar.github.io/kongdash
+ arch = x86_64
+ license = MIT
+ provides = kongdash
+ source = https://github.com/ajaysreedhar/kongdash/releases/download/v0.3.0/kongdash-0.3.0-linux-x64.tar.gz
+ sha256sums = d74c68e08109783cb9160daccdc91ead58c60ebbb41a1a6253a55219b0c7e0f0
+
+pkgname = kongdash-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53552358b4de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Matthew Ellison <matt(at)arroyo(dot)io>
+
+_pkgname='kongdash'
+pkgname="${_pkgname}-bin"
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="ORY Hydra is a hardened, certified OAuth2 and OpenID Connect server optimized for low-latency, high throughput, and low resource consumption."
+arch=('x86_64')
+url="https://ajaysreedhar.github.io/kongdash"
+license=('MIT')
+depends=()
+provides=("${_pkgname}")
+source=("https://github.com/ajaysreedhar/kongdash/releases/download/v${pkgver}/kongdash-${pkgver}-linux-x64.tar.gz")
+sha256sums=('d74c68e08109783cb9160daccdc91ead58c60ebbb41a1a6253a55219b0c7e0f0')
+
+package() {
+ mkdir -p "${pkgdir}/opt"
+ cp -pr "${srcdir}/kongdash-${pkgver}-linux-x64/kongdash-x64" "${pkgdir}/opt/"
+
+ install -m755 -D "${srcdir}/kongdash-${pkgver}-linux-x64/kongdash-x64/resources/kongdash.desktop" "${pkgdir}/usr/local/share/applications/kongdash.desktop"
+}
+