summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
-rw-r--r--kosqlite.install7
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a28dcb8ba58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kosqlite
+ pkgdesc = KoSQLite is a GUI frontend for SQLite written in Qt5
+ pkgver = 0.1.0
+ pkgrel = 3
+ url = http://karoljkocmaros.blogspot.com/p/ko.html
+ install = kosqlite.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = qt5-base>=5.2.1
+ source = kosqlite-0.1.0.zip::https://master-dl.sourceforge.net/project/kosqlite/Source/kosqlite.zip
+ sha256sums = 1ed6e4f54e089f88261eccc0af95af53782ffc8d157d3dea3a02b7321cea0775
+
+pkgname = kosqlite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dad3c76f9e16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+#Maintainer: Kočmaroš Karolj <karlosmunjos at gmail dot com>
+
+pkgname=kosqlite
+pkgver=0.1.0
+pkgrel=3
+pkgdesc="KoSQLite is a GUI frontend for SQLite written in Qt5"
+arch=('i686' 'x86_64')
+url="http://karoljkocmaros.blogspot.com/p/ko.html"
+license=('LGPL')
+install=${pkgname}.install
+depends=('qt5-base>=5.2.1')
+source=(${pkgname}-${pkgver}.zip::"https://master-dl.sourceforge.net/project/kosqlite/Source/kosqlite.zip")
+sha256sums=('1ed6e4f54e089f88261eccc0af95af53782ffc8d157d3dea3a02b7321cea0775')
+
+build()
+{
+ cd $srcdir/trunk
+ qmake || return 1
+ make || return 1
+}
+
+package()
+{
+ cd $srcdir/trunk
+ make INSTALL_ROOT="${pkgdir}" install
+}
diff --git a/kosqlite.install b/kosqlite.install
new file mode 100644
index 000000000000..0d53f0e440a4
--- /dev/null
+++ b/kosqlite.install
@@ -0,0 +1,7 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}