summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--koules-1.4-multiple-definition.patch17
3 files changed, 27 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98a387af2237..8a0d336a3bee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = koules
pkgdesc = A fast arcade game based on fundamental law of bodies attraction
pkgver = 1.4
- pkgrel = 5
+ pkgrel = 6
url = http://www.ucw.cz/~hubicka/koules/English/
arch = i686
arch = x86_64
license = GPL
makedepends = imake
- makedepends = xextproto
- makedepends = xproto
+ makedepends = xorgproto
depends = dialog
depends = libx11
depends = libxext
@@ -16,11 +15,12 @@ pkgbase = koules
source = http://www.ucw.cz/~hubicka/koules/packages/koules1.4-src.tar.gz
source = koules-1.4-gcc3.patch
source = koules-1.4-alsa-oss.patch
+ source = koules-1.4-multiple-definition.patch
source = koules.desktop
md5sums = 0a5ac9e57c8b72e9fc200bc98273235c
md5sums = ccc92d4ab7d61ca482d30192a5ee83ec
md5sums = cbb37f907f7e8726be364434b75b66a9
+ md5sums = 0efb694f178065e2fdbc98f4445d3d38
md5sums = fb3cd393464214643c239ac4350f963a
pkgname = koules
-
diff --git a/PKGBUILD b/PKGBUILD
index 0eeef4bf9052..c9a73ff252d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,22 @@
# Contributor: Gyo <nucleogeek_at_gmail_dot_com>
pkgname=koules
pkgver=1.4
-pkgrel=5
+pkgrel=6
pkgdesc="A fast arcade game based on fundamental law of bodies attraction"
arch=('i686' 'x86_64')
url="http://www.ucw.cz/~hubicka/koules/English/"
license=('GPL')
depends=('dialog' 'libx11' 'libxext' 'alsa-oss')
-makedepends=('imake' 'xextproto' 'xproto')
+makedepends=('imake' 'xorgproto')
source=(http://www.ucw.cz/~hubicka/koules/packages/$pkgname$pkgver-src.tar.gz
$pkgname-$pkgver-gcc3.patch
$pkgname-$pkgver-alsa-oss.patch
+ $pkgname-$pkgver-multiple-definition.patch
koules.desktop)
md5sums=('0a5ac9e57c8b72e9fc200bc98273235c'
'ccc92d4ab7d61ca482d30192a5ee83ec'
'cbb37f907f7e8726be364434b75b66a9'
+ '0efb694f178065e2fdbc98f4445d3d38'
'fb3cd393464214643c239ac4350f963a')
prepare() {
@@ -26,6 +28,8 @@ prepare() {
rm -f oss-redir.c
patch -p1 < "$srcdir/$pkgname-$pkgver-alsa-oss.patch"
+ patch -p1 < "$srcdir/$pkgname-$pkgver-multiple-definition.patch"
+
# some source modifications
sed -i \
-e "/^KOULESDIR/s:=.*:=/usr/bin:" \
diff --git a/koules-1.4-multiple-definition.patch b/koules-1.4-multiple-definition.patch
new file mode 100644
index 000000000000..e6e043206ce4
--- /dev/null
+++ b/koules-1.4-multiple-definition.patch
@@ -0,0 +1,17 @@
+Remove duplicated global symbol, controls[] is already defined in koules.c
+
+Fixes this link error:
+/usr/bin/ld: server.o:(.bss+0x10000): multiple definition of `controls'; koules.o:(.bss+0x7d160): first defined here
+
+diff --git a/server.c b/server.c
+index 5463244..e8e80f4 100644
+--- a/server.c
++++ b/server.c
+@@ -80,7 +80,6 @@ static long sizes[MAXPACKET];
+ static long isizes[MAXPACKET];
+ char acceled[5];
+ #endif
+-struct control controls[MAXROCKETS];
+ static unsigned char Clientmap[5];
+ static int Socket;
+ /*static int tbreak; */