summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD45
-rw-r--r--kphotoalbum.install11
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84ee9451a076
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = kphotoalbum-git
+ pkgdesc = KDE Photo Album, picture collection manager - latest git version.
+ pkgver = 2013.10.11
+ pkgrel = 1
+ epoch = 1
+ url = http://www.kphotoalbum.org/
+ install = kphotoalbum.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = automoc4
+ makedepends = kdeedu-marble
+ makedepends = kdemultimedia-mplayerthumbs
+ makedepends = git
+ depends = kdebase-runtime
+ depends = libkipi
+ depends = libkexiv2
+ depends = libkdcraw
+ optdepends = kdeedu-marble: integration with Marble
+ optdepends = kipi-plugins: add extra functionality
+ optdepends = kdemultimedia-mplayerthumbs: video thumbnails
+ provides = kphotoalbum
+ conflicts = kphotoalbum
+ source = kphotoalbum::git://anongit.kde.org/kphotoalbum.git
+ md5sums = SKIP
+
+pkgname = kphotoalbum-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e0bb5018d1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: Laurent Carlier <lordheavym@gmail.com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Gilles CHAUVIN <gcnweb ][ gmail ? com>
+# Contributor: Jonathan Schaeffer <joschaeffer ][ gmail ? com>
+# Contributor: chfoxli <lg ][ romandie ? com>
+# Maintainer: SanskritFritz (gmail)
+
+pkgname=kphotoalbum-git
+_gitname="kphotoalbum"
+pkgver=2013.10.11
+pkgrel=1
+epoch=1
+pkgdesc="KDE Photo Album, picture collection manager - latest git version."
+url="http://www.kphotoalbum.org/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('kdebase-runtime' 'libkipi' 'libkexiv2' 'libkdcraw')
+makedepends=('cmake' 'automoc4' 'kdeedu-marble' 'kdemultimedia-mplayerthumbs' 'git')
+optdepends=('kdeedu-marble: integration with Marble'
+ 'kipi-plugins: add extra functionality'
+ 'kdemultimedia-mplayerthumbs: video thumbnails')
+install=kphotoalbum.install
+provides=('kphotoalbum')
+conflicts=('kphotoalbum')
+source=("$_gitname::git://anongit.kde.org/kphotoalbum.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git log -1 --format="%cd" --date=short | sed 's|-|.|g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DQT_QMAKE_EXECUTABLE=qmake4 \
+ .
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ make DESTDIR=${pkgdir} install
+}
diff --git a/kphotoalbum.install b/kphotoalbum.install
new file mode 100644
index 000000000000..e70c054ec6ad
--- /dev/null
+++ b/kphotoalbum.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}