summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
-rw-r--r--kubeman.desktop10
-rw-r--r--kubeman.pngbin0 -> 35049 bytes
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2216a18875a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = kubeman-appimage
+ pkgdesc = The Hero that Kubernetes deserves (kubernetes management GUI)
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/walmartlabs/kubeman
+ arch = x86_64
+ license = Apache
+ depends = fuse
+ provides = kubeman
+ conflicts = kubeman
+ noextract = kubeman.0.5.0.appimage
+ options = !strip
+ source = kubeman.0.5.0.appimage::https://github.com/walmartlabs/kubeman/releases/download/0.5.0/kubeman.0.5.0.appimage
+ source = kubeman.desktop
+ source = kubeman.png
+ sha256sums = 1f64e92422e85fe57b396c955c5e2ce845635809ece8d15f663af778e9113134
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = kubeman-appimage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3915bf94330
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: tercean <cg@zknt.org>
+pkgname=kubeman-appimage
+pkgver=0.5.0
+pkgrel=1
+pkgdesc='The Hero that Kubernetes deserves (kubernetes management GUI)'
+arch=('x86_64')
+url='https://github.com/walmartlabs/kubeman'
+license=('Apache')
+provides=('kubeman')
+conflicts=('kubeman')
+depends=('fuse')
+options=(!strip)
+_appimage="kubeman.${pkgver}.appimage"
+source=(
+ "kubeman.${pkgver}.appimage::https://github.com/walmartlabs/kubeman/releases/download/${pkgver}/kubeman.${pkgver}.appimage"
+ "kubeman.desktop"
+ "kubeman.png"
+ )
+noextract=("${_appimage}")
+sha256sums=(
+ '1f64e92422e85fe57b396c955c5e2ce845635809ece8d15f663af778e9113134'
+ 'SKIP'
+ 'SKIP'
+ )
+
+package() {
+ install -Dm755 $_appimage "$pkgdir"/usr/bin/kubeman
+ chmod +x "${pkgdir}/usr/bin/kubeman"
+
+ install -Dm644 "kubeman.desktop" "${pkgdir}/usr/share/applications/kubeman.desktop"
+ install -Dm644 "kubeman.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/kubeman.png"
+}
diff --git a/kubeman.desktop b/kubeman.desktop
new file mode 100644
index 000000000000..a135575478fe
--- /dev/null
+++ b/kubeman.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Kubeman
+Comment=The Hero that Kubernetes deserves
+Exec=kubeman
+Terminal=false
+Type=Application
+Icon=kubeman
+StartupWMClass=kubeman
+X-AppImage-Version=0.5.0
+Categories=Internet;
diff --git a/kubeman.png b/kubeman.png
new file mode 100644
index 000000000000..ef1cf6a6a028
--- /dev/null
+++ b/kubeman.png
Binary files differ