summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index babf4c8178af..3cda1c058f71 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = kubeshark
arch = aarch64
license = apache
makedepends = go
+ options = !lto
source = kubeshark-52.1.66.tar.gz::https://github.com/kubeshark/kubeshark/archive/v52.1.66.tar.gz
sha256sums = 2f8af32a5f783ed7b89611811b83b2e667490ff1c1803d17323048d6af10114f
diff --git a/PKGBUILD b/PKGBUILD
index ae8412c86e8e..cc5e4afe3b81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,10 @@ makedepends=(
'go'
)
+# no idea why --flto=auto is added to the LDFLAGS with a format
+# causing an issue with the compiler.
+options=('!lto')
+
_latest() {
curl -s https://api.github.com/repos/kubeshark/kubeshark/releases | jq -r '.[0].tag_name'
}