summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e23e608dc5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = kubetail
+ pkgdesc = Bash script that enables you to aggregate (tail/follow) logs from multiple pods into one stream
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://github.com/johanhaleby/kubetail
+ arch = any
+ license = Apache
+ depends = kubectl-bin
+ source = https://github.com/johanhaleby/kubetail/archive/1.3.1.tar.gz
+ md5sums = 460d9980033b22631fde19002537162f
+
+pkgname = kubetail
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a4915aa3b5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Wael Nasreddine <wael.nasreddine@gmail.com>
+
+pkgname=kubetail
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Bash script that enables you to aggregate (tail/follow) logs from multiple pods into one stream"
+arch=('any')
+url="https://github.com/johanhaleby/kubetail"
+license=('Apache')
+depends=('kubectl-bin')
+source=(https://github.com/johanhaleby/$pkgname/archive/$pkgver.tar.gz)
+md5sums=('460d9980033b22631fde19002537162f')
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ mkdir -p "$pkgdir/usr/bin"
+ install -m755 kubetail "$pkgdir/usr/bin/kubetail"
+}
+