aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--Makefile4
-rw-r--r--PKGBUILD36
-rw-r--r--README21
-rw-r--r--kx3util2
6 files changed, 49 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73231ca59835..adb6677a7e56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = kx3util
pkgdesc = Elecraft KX3 Utility
- pkgver = 1.16.6.25
- pkgrel = 2
- url = http://www.elecraft.com/KX3/KX3_software.htm
+ pkgver = 1.23.4.23
+ pkgrel = 1
+ url = https://elecraft.com/pages/kx3-high-perofrmance-portable-transceiver-firmware-and-utility
arch = x86_64
license = custom
depends = lib32-glibc
depends = lib32-libstdc++5
depends = lib32-gtk2
+ depends = curl
provides = kx3util
- source = http://www.elecraft.com/software/KX3/KX3UtilityLINUX_1_16_6_25.tgz
- md5sums = 1c63b7f43b994ddf4f1c12add2cfaa36
+ source = https://ftp.elecraft.com/KX3/Utilities/KX3UtilityLINUX64BIT_1_23_4_23.tar.gz
+ md5sums = f46a2786b81bcb82d874c9e5c00427ac
pkgname = kx3util
-
diff --git a/.gitignore b/.gitignore
index 30c4dea51842..4f864b4a7bfd 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
src/
pkg/
-kx3util*.pkg.tar.xz
-KX3Utility*.tgz
+kx3util*.pkg.tar.zst
+KX3Utility*.tar.gz
diff --git a/Makefile b/Makefile
index 8ed5fa288caf..3629843a5d00 100644
--- a/Makefile
+++ b/Makefile
@@ -7,7 +7,7 @@ srcinfo:
makepkg --printsrcinfo > .SRCINFO
clean:
- $(RM) kx3util*.pkg.tar.xz
- $(RM) KX3Utility*.tgz
+ $(RM) kx3util*.pkg.tar.zst
+ $(RM) KX3Utility*.tar.gz
$(RM) -r pkg
$(RM) -r src
diff --git a/PKGBUILD b/PKGBUILD
index 9d6423ba9f55..dcdb6a52fe92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Clement Poisson <clement@poisson.me>
pkgname=kx3util
-pkgver=1.16.6.25
-pkgrel=2
+pkgver=1.23.4.23
+pkgrel=1
epoch=
pkgdesc="Elecraft KX3 Utility"
arch=("x86_64")
-url="http://www.elecraft.com/KX3/KX3_software.htm"
+url="https://elecraft.com/pages/kx3-high-perofrmance-portable-transceiver-firmware-and-utility"
license=("custom")
groups=()
-depends=("lib32-glibc" "lib32-libstdc++5" "lib32-gtk2")
+depends=("lib32-glibc" "lib32-libstdc++5" "lib32-gtk2" "curl")
makedepends=()
checkdepends=()
optdepends=()
@@ -19,9 +19,9 @@ backup=()
options=()
install=
changelog=
-source=("http://www.elecraft.com/software/KX3/KX3UtilityLINUX_1_16_6_25.tgz")
+source=("https://ftp.elecraft.com/KX3/Utilities/KX3UtilityLINUX64BIT_1_23_4_23.tar.gz")
noextract=()
-md5sums=('1c63b7f43b994ddf4f1c12add2cfaa36')
+md5sums=('f46a2786b81bcb82d874c9e5c00427ac')
validpgpkeys=()
package() {
@@ -32,21 +32,17 @@ package() {
# License
install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd "${srcdir}/kx3util_1_16_6_25"
+ # Alias executable
+ install -Dm755 ../kx3util "${pkgdir}/usr/local/bin/kx3util"
- # Main Binary
- install -Dm755 kx3util "${pkgdir}/usr/local/bin/kx3util"
+ cd "${srcdir}/KX3UtilityLINUX64BIT_1_23_4_23"
- # Libraries
- install -d "${pkgdir}/usr/local/lib/${pkgname}"
- install -Dm755 "kx3util Libs"/* "${pkgdir}/usr/local/lib/${pkgname}"
- # -- create a link to the expected install location
- ln -s "/usr/local/lib/${pkgname}" "${pkgdir}/usr/local/bin/kx3util Libs"
+ # Main Contents
+ install -d "${pkgdir}/usr/local/etc/${pkgname}"
+ install -Dm755 kx3util "${pkgdir}/usr/local/etc/${pkgname}/kx3util"
- # Help
- install -d "${pkgdir}/etc/${pkgname}/Help"
- # -- help files need world read in order to open in the browser
- install -Dm744 "Help"/* "${pkgdir}/etc/${pkgname}/Help"
- # -- create a link to the expected install location
- ln -s "/etc/${pkgname}/Help" "${pkgdir}/usr/local/bin/Help"
+ # Libraries
+ cp -r "Libs" "${pkgdir}/usr/local/etc/${pkgname}"
+ cp -r "Help" "${pkgdir}/usr/local/etc/${pkgname}"
+ cp -r "Resources" "${pkgdir}/usr/local/etc/${pkgname}"
}
diff --git a/README b/README
new file mode 100644
index 000000000000..e2e4bf6c65e9
--- /dev/null
+++ b/README
@@ -0,0 +1,21 @@
+# kx3util
+
+## Installation Notes
+The program requires that the 'Help', 'Libs', and 'Resources' directories are
+all siblings to the main executable. In the previous version, this was done by
+creating symbolic links to the bin directory the main executable lived in.
+
+In the current release, all package files are installed together in an etc
+directory, and a simple shell script that calls the main executable is installed
+into the bin directory instead. This was done because the application was not
+able to detect the help directory when installed in this manner.
+
+## Help Notes
+The help documentation requires a gtkhtml library to be installed, which is not
+called out in their installation notes. At the time I put the package together,
+installing this library required packages from the AUR which were failing to
+install on my machine.
+
+Instead of opening the help directly in the application, the utility provides
+the ability to open the help documents in a browser instead. This has been
+tested to work as an alternative. \ No newline at end of file
diff --git a/kx3util b/kx3util
new file mode 100644
index 000000000000..4c905d716c95
--- /dev/null
+++ b/kx3util
@@ -0,0 +1,2 @@
+#! /usr/bin/env bash
+/usr/local/etc/kx3util/kx3util \ No newline at end of file