summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
-rw-r--r--kxpautility.15
-rw-r--r--kxpautility.desktop14
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05c66018ade3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = kxpautility
+ pkgdesc = Elecraft Factory APP for use with the KXPA Amplifier - Ham Radio.
+ pkgver = 19_9_6
+ pkgrel = 1
+ url = https://ftp.elecraft.com/KXPA/Manuals%20Downloads/
+ arch = x86_64
+ license = custom:ELECRAFT
+ depends = gcc-libs
+ depends = gtk2
+ depends = curl
+ depends = hamradio-menus
+ options = !strip
+ source = https://ftp.elecraft.com/KXPA/Utilities/KXPAUtilityLINUX64BIT_19_9_6.tar.gz
+ source = kxpautility.1
+ source = kxpautility.desktop
+ md5sums = 8a9a3141adab81b4414ff6939e213f5a
+ md5sums = d4ff1efcc05a56a3d561f43fd6919fe1
+ md5sums = 37e6821f1ceae8b51fae5cd8b4dbceb7
+ sha256sums = fced6763dd4a7fea4021612f5cdfa34882fb9f2ce65b2d7cad06be47656685fe
+ sha256sums = a099aaa86632a1ccde1487bfe4179b69605dd3b70aa28be9e5ed3ff0e761e5ff
+ sha256sums = efc093d259ed561756bd0c262dc05ab932a88b2e01c42622dc0d67da4a5dcc8a
+
+pkgname = kxpautility
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e49303c9ee4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+
+pkgname=kxpautility
+_pkgname=KXPAUtilityLINUX64BIT
+__pkgname=KXPAUtilityLINUX
+pkgver=19_9_6
+pkgrel=1
+pkgdesc="Elecraft Factory APP for use with the KXPA Amplifier - Ham Radio."
+arch=('x86_64')
+url="https://ftp.elecraft.com/KXPA/Manuals%20Downloads/"
+license=('custom:ELECRAFT')
+depends=('gcc-libs' 'gtk2' 'curl' 'hamradio-menus')
+options=('!strip')
+source=(https://ftp.elecraft.com/KXPA/Utilities/${_pkgname}_$pkgver.tar.gz
+ $pkgname.1
+ $pkgname.desktop)
+
+package() {
+ cd $srcdir/${__pkgname}_$pkgver
+
+ install -d $pkgdir/usr/share/$pkgname
+ cp -a * $pkgdir/usr/share/$pkgname
+
+ mkdir -p $pkgdir/usr/bin
+ install -D -m 755 ../$pkgname.1 $pkgdir/usr/bin/$pkgname
+
+ mkdir -p $pkgdir/usr/share/{applications,pixmaps,licenses/$pkgname}
+ install -D -m 644 Help/License.rtf $pkgdir/usr/share/licenses/$pkgname
+ install -D -m 644 Resources/icon-48.png $pkgdir/usr/share/pixmaps/kxpautility.png
+ install -D -m 644 ../$pkgname.desktop $pkgdir/usr/share/applications
+
+ chmod 644 $pkgdir/usr/share/$pkgname/Help/*
+}
+md5sums=('8a9a3141adab81b4414ff6939e213f5a'
+ 'd4ff1efcc05a56a3d561f43fd6919fe1'
+ '37e6821f1ceae8b51fae5cd8b4dbceb7')
+sha256sums=('fced6763dd4a7fea4021612f5cdfa34882fb9f2ce65b2d7cad06be47656685fe'
+ 'a099aaa86632a1ccde1487bfe4179b69605dd3b70aa28be9e5ed3ff0e761e5ff'
+ 'efc093d259ed561756bd0c262dc05ab932a88b2e01c42622dc0d67da4a5dcc8a')
diff --git a/kxpautility.1 b/kxpautility.1
new file mode 100644
index 000000000000..445a59238f16
--- /dev/null
+++ b/kxpautility.1
@@ -0,0 +1,5 @@
+#!/bin/sh
+mkdir -p $HOME/kxpautility
+cd $HOME/kxpautility
+cp -ua /usr/share/kxpautility/* .
+exec ./kxpautil
diff --git a/kxpautility.desktop b/kxpautility.desktop
new file mode 100644
index 000000000000..20c8c5c8c711
--- /dev/null
+++ b/kxpautility.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Name=KXPA-Utility
+Name[en_US]=KXPA-Utility
+Comment=Elecraft KHPA Control Utility
+Comment[en_US]=Elecraft KHPA Control Utility
+Exec=kxpautility
+Icon=kxpautility
+MimeType=text/plain
+StartupNotify=false
+Terminal=false
+Type=Application
+Categories=Network;HamRadio;
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false