summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD39
-rw-r--r--l3afpad.appdata.xml24
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdabf921840d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = l3afpad-budlabs
+ pkgdesc = Simple plain text editor for GTK 3 (budlabs fork)
+ pkgver = 2022.07.06.1
+ pkgrel = 6
+ url = https://github.com/budRich/l3afpad
+ arch = x86_64
+ license = GPL2
+ makedepends = intltool
+ depends = gtk3
+ provides = l3afpad
+ conflicts = l3afpad
+ source = https://github.com/budRich/l3afpad/archive/2022.07.06.1/l3afpad-budlabs-2022.07.06.1.tar.gz
+ source = l3afpad.appdata.xml
+ sha256sums = 4ee3cde9fca76e46553d1032ef3bceb95d6f90ba4753066b70919ae01a143f77
+ sha256sums = 742e3d2d23e6bad8f56dccafdccc6c1b36cebdb7dd178b1f19942fcb37fe3ff8
+
+pkgname = l3afpad-budlabs
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3bda0231b3ee
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!l3afpad.appdata.xml
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2de1c8cc74c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: budRich <at budlabs>
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Steven Honeyman <stevenhoneyman at gmail com>
+# Contributor: nbvcxz (b4283)
+
+pkgname=l3afpad-budlabs
+_pkgname=${pkgname%-*}
+pkgver=2022.07.06.1
+pkgrel=6
+pkgdesc='Simple plain text editor for GTK 3 (budlabs fork)'
+arch=('x86_64')
+url='https://github.com/budRich/l3afpad'
+license=('GPL2')
+depends=('gtk3')
+makedepends=('intltool')
+conflicts=(l3afpad)
+provides=(l3afpad)
+source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+ 'l3afpad.appdata.xml')
+sha256sums=('4ee3cde9fca76e46553d1032ef3bceb95d6f90ba4753066b70919ae01a143f77'
+ '742e3d2d23e6bad8f56dccafdccc6c1b36cebdb7dd178b1f19942fcb37fe3ff8')
+
+prepare() {
+ cd $_pkgname-$pkgver
+ ./autogen.sh
+}
+
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr --disable-print --disable-statistics
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../$_pkgname.appdata.xml "$pkgdir/usr/share/metainfo/$_pkgname.appdata.xml"
+ rm -r "$pkgdir/usr/share/pixmaps/"
+}
diff --git a/l3afpad.appdata.xml b/l3afpad.appdata.xml
new file mode 100644
index 000000000000..514940b14db1
--- /dev/null
+++ b/l3afpad.appdata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop-application">
+ <id>com.github.l3afpad</id>
+ <launchable type="desktop-id">l3afpad.desktop</launchable>
+ <name>L3afpad</name>
+ <summary>Simple text editor</summary>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPL-2.0</project_license>
+ <description>
+ <p>
+ L3afpad is a simple GTK text editor that emphasizes simplicity. As development
+ focuses on keeping weight down to a minimum, only the most essential features
+ are implemented in the editor. L3afpad is simple to use, is easily compiled,
+ requires few libraries, and starts up quickly.
+ </p>
+ </description>
+ <screenshots>
+ <screenshot type="default">
+ <image>https://cn.opendesktop.org/img/hive/content-pre1/144892-1.png</image>
+ </screenshot>
+ </screenshots>
+ <url type="bugtracker">https://github.com/stevenhoneyman/l3afpad/issues</url>
+ <url type="homepage">https://github.com/stevenhoneyman/l3afpad</url>
+</component>