summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c07bfc6d4c78..43f80254818f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = labplot-kf5
pkgdesc = A free software data analysis and visualization application, for two and three-dimensional graphical presentation of data sets and functions.
- pkgver = 2.4.0
- pkgrel = 3
+ pkgver = 2.5.0
+ pkgrel = 1
url = http://labplot.sourceforge.net/
install = labplot-kf5.install
arch = i686
@@ -12,15 +12,17 @@ pkgbase = labplot-kf5
makedepends = kdoctools
makedepends = kdesignerplugin
makedepends = knewstuff
- depends = kdebase-runtime
depends = gsl
- depends = kdelibs4support
depends = fftw
depends = netcdf
depends = cfitsio
- source = http://download.kde.org/stable/labplot/2.4.0/labplot-2.4.0-kf5.tar.xz
+ depends = qt5-serialport
+ depends = hicolor-icon-theme
+ depends = syntax-highlighting
+ depends = kxmlgui
+ source = http://download.kde.org/stable/labplot/2.5.0/labplot-2.5.0.tar.xz
source = labplot-kf5.install
- md5sums = fe7cdefc5abfae5321b77973450aaa1d
+ md5sums = 49dab9faab6e7498a1127d096935284f
md5sums = 7dd4a598d34b8e21411dec1247752d99
pkgname = labplot-kf5
diff --git a/PKGBUILD b/PKGBUILD
index 85bb34ac34ee..a5cc525d83e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Contributor: XavierCLL <xavier.corredor.llano (a) gmail.com>
pkgname=labplot-kf5
-pkgver=2.4.0
-pkgrel=3
+pkgver=2.5.0
+pkgrel=1
pkgdesc="A free software data analysis and visualization application, for two and three-dimensional graphical presentation of data sets and functions."
arch=('i686' 'x86_64')
url='http://labplot.sourceforge.net/'
license=('GPL')
-depends=('kdebase-runtime' 'gsl' 'kdelibs4support' 'fftw' 'netcdf' 'cfitsio')
+depends=('gsl' 'fftw' 'netcdf' 'cfitsio' 'qt5-serialport' 'hicolor-icon-theme' 'syntax-highlighting' 'kxmlgui')
makedepends=('cmake' 'extra-cmake-modules' 'kdoctools' 'kdesignerplugin' 'knewstuff')
-source=("http://download.kde.org/stable/labplot/${pkgver}/labplot-${pkgver}-kf5.tar.xz"
+source=("http://download.kde.org/stable/labplot/${pkgver}/labplot-${pkgver}.tar.xz"
"labplot-kf5.install")
-md5sums=('fe7cdefc5abfae5321b77973450aaa1d'
+md5sums=('49dab9faab6e7498a1127d096935284f'
'7dd4a598d34b8e21411dec1247752d99')
install='labplot-kf5.install'
@@ -23,7 +23,7 @@ prepare() {
build() {
cd build
- cmake ../labplot-${pkgver}-kf5 \
+ cmake ../labplot-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON \