summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..974a821205b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lapidoc-man
+ pkgdesc = Lua API Functions Man Pages
+ pkgver = r5.99041d0
+ pkgrel = 1
+ url = https://github.com/patrickschulz/lapidoc-man
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = lua
+ source = git+https://github.com/patrickschulz/lapidoc-man.git
+ sha256sums = SKIP
+
+pkgname = lapidoc-man
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0aad1d97cd83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Patrick Kurth <p.kurth@posteo.de>
+
+pkgname=lapidoc-man
+pkgver=r5.99041d0
+pkgrel=1
+pkgdesc="Lua API Functions Man Pages"
+arch=('any')
+url="https://github.com/patrickschulz/lapidoc-man"
+source=("git+https://github.com/patrickschulz/lapidoc-man.git")
+sha256sums=('SKIP')
+depends=()
+makedepends=('git' 'lua')
+license=('MIT')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/man/man3"
+ cd "${srcdir}/${pkgname}"
+ install -m 644 -C man3/* "${pkgdir}/usr/share/man/man3/"
+}