summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ecd375b192bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Sun Aug 26 15:26:16 UTC 2018
+pkgbase = lastfreemind
+ pkgdesc = Command line tool to keep the last version of mindmaps from a collection of freemind mindmaps
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://gitlab.com/plenae/lastfreemind
+ arch = any
+ license = GPL3
+ depends = python-lxml
+ source = https://gitlab.com/plenae/lastfreemind/-/archive/v0.0.2/lastfreemind-v0.0.2.tar.bz2
+ sha512sums = ec4047a32bde86b7fc3cea380f81aac21851a2909c7a3de95551a01db3c501dc28ef1d2b13bb5a3d4b401037c4c2460508cf81287decae5a98f7bddf6bda6000
+
+pkgname = lastfreemind
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2032cefe1efb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Pieter Lenaerts <pieter.aj.lenaerts@gmail.com>
+
+pkgname=lastfreemind
+pkgver=0.0.2
+pkgrel=1
+pkgdesc='Command line tool to keep the last version of mindmaps from a collection of freemind mindmaps'
+arch=('any')
+url='https://gitlab.com/plenae/lastfreemind'
+license=('GPL3')
+depends=('python-lxml')
+source=("https://gitlab.com/plenae/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.bz2")
+sha512sums=('ec4047a32bde86b7fc3cea380f81aac21851a2909c7a3de95551a01db3c501dc28ef1d2b13bb5a3d4b401037c4c2460508cf81287decae5a98f7bddf6bda6000')
+
+package() {
+ cd $pkgname-v$pkgver
+ python setup.py install --root="${pkgdir}" --optimize=1
+}