summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--lpm-flags.patch25
3 files changed, 33 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 542f060ba476..394926163974 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ldpl-git
pkgdesc = COBOL inspired language, designed to be expressive, fast, readable and easy to learn.
- pkgver = 3.0.5.r21.72d49f8
+ pkgver = 4.4.r41.d27b8e4
pkgrel = 1
url = https://www.ldpl-lang.org/
arch = x86_64
@@ -12,8 +12,10 @@ pkgbase = ldpl-git
conflicts = ldpl
source = git+https://github.com/Lartu/ldpl.git
source = dont-do-mandb.patch
+ source = lpm-flags.patch
md5sums = SKIP
- md5sums = dc344057eee2032c7b49562b507db99a
+ md5sums = 2764e75489cfc352d2bad67f554d2cc6
+ md5sums = c4cb95cca6596d629299ac58e0d0e551
pkgname = ldpl-git
diff --git a/PKGBUILD b/PKGBUILD
index a16f1f35af40..22d480a32496 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@ depends=('gcc-libs')
makedepends=('git' 'awk')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+https://github.com/Lartu/ldpl.git" "dont-do-mandb.patch")
-md5sums=('SKIP' '2764e75489cfc352d2bad67f554d2cc6')
+source=("git+https://github.com/Lartu/ldpl.git" "dont-do-mandb.patch" "lpm-flags.patch")
+md5sums=('SKIP' '2764e75489cfc352d2bad67f554d2cc6' 'c4cb95cca6596d629299ac58e0d0e551')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -22,11 +22,12 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
patch -p1 -i "$srcdir/dont-do-mandb.patch"
+ patch -p1 -i "$srcdir/lpm-flags.patch"
}
build() {
cd "$srcdir/${pkgname%-git}/src"
- make LFLAGS="$LDFLAGS"
+ make LFLAGS="$LDFLAGS" LPMFLAGS="$CXXFLAGS $LDFLAGS"
}
package() {
diff --git a/lpm-flags.patch b/lpm-flags.patch
new file mode 100644
index 000000000000..2a2fad85b433
--- /dev/null
+++ b/lpm-flags.patch
@@ -0,0 +1,25 @@
+From f35d26ded650c80f3f18b179db524c9aa723e4b9 Mon Sep 17 00:00:00 2001
+From: Ignacio Losiggio <iglosiggio@dc.uba.ar>
+Date: Sun, 15 Dec 2019 18:06:10 -0300
+Subject: [PATCH] makefile: Make lpm flags configurable
+
+---
+ src/makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/makefile b/src/makefile
+index 7cb45fa..052d582 100644
+--- a/src/makefile
++++ b/src/makefile
+@@ -34,7 +34,7 @@ endif
+
+ all: $(OBJS) ldpl.1
+ $(CXX) -g $(OBJS) -o $(OUT) $(LFLAGS) $(CROSS)
+- ./ldpl ../lpm/lpm.ldpl -o=lpm
++ ./ldpl ../lpm/lpm.ldpl -f="$(LPMFLAGS)" -o=lpm
+
+ ldpl.o: ldpl.cpp ldpl_lib.cpp
+ awk -f lib-to-string.awk ldpl_lib.cpp > ldpl_included_lib.cpp
+--
+2.24.1
+