summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD70
-rw-r--r--legend-of-grimrock7
-rw-r--r--legend-of-grimrock.desktop4
5 files changed, 55 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73c646cb3fa4..f8c031d95a81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = legend-of-grimrock
pkgdesc = A 3D grid-based dungeon crawler inspired by classic 1980s and 1990s action role-playing games Dungeon Master, Eye of the Beholder and Ultima Underworld.
- pkgver = 20130515
- pkgrel = 3
- url = http://www.grimrock.net/
+ pkgver = 2.1.0.5
+ pkgrel = 1
+ url = https://www.gog.com/game/legend_of_grimrock
arch = i686
arch = x86_64
- license = custom
+ license = custom:commercial
depends = freeimage
depends = minizip
depends = sdl
@@ -18,11 +18,12 @@ pkgbase = legend-of-grimrock
depends = libogg
depends = libxext
depends = desktop-file-utils
- optdepends = libtxc_dxtn: For Mesa S3TC support.
- source = local://LegendOfGrimrock-Linux-2013-05-15.sh
+ source = legend-of-grimrock
source = legend-of-grimrock.desktop
- sha256sums = 005066be6ce12ba342e499369070113c6b66a9bea03c6ecb1e5fd0758eb0c39d
- sha256sums = a989d2d0d896ec4adaf3d66e19050c519d9e58efc8d588a51ab0185283bf21fb
+ source = gog_legend_of_grimrock_2.1.0.5.sh::gogdownloader://legend_of_grimrock/en3installer3
+ sha256sums = e72d4212b2394bd6038ac13ada2717756b4ce4a9370bbe96501ab1c489410861
+ sha256sums = b93a443998d1fbe415c7228c7d173ea0226dabd028badbe0ce8f6f13a93de819
+ sha256sums = c5fa1064977e4df4389d45be12a655f151227d08a22f3058bc4bc6e9627d1af1
pkgname = legend-of-grimrock
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c4173052700c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+gog_legend_of_grimrock_*.sh
+legend-of-grimrock-*.pkg.tar
+
diff --git a/PKGBUILD b/PKGBUILD
index 3fd33e8337d1..5c842ef9d538 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,43 +4,41 @@
# henning mueller <henning@orgizm.net>
pkgname=legend-of-grimrock
-pkgdesc='A 3D grid-based dungeon crawler inspired by classic 1980s and 1990s action role-playing games Dungeon Master, Eye of the Beholder and Ultima Underworld.'
-url='http://www.grimrock.net/'
-_pkgdate=2013-05-15
-pkgver=20130515
-pkgrel=3
+pkgver=2.1.0.5
+pkgrel=1
+pkgdesc="A 3D grid-based dungeon crawler inspired by classic 1980s and 1990s action role-playing games Dungeon Master, Eye of the Beholder and Ultima Underworld."
+url="https://www.gog.com/game/legend_of_grimrock"
arch=(i686 x86_64)
-license=(custom)
-PKGEXT=.pkg.tar
-depends=(
- freeimage minizip sdl libvorbis freetype2 zlib openal libgl libx11 libogg
- libxext desktop-file-utils
-)
-optdepends=('libtxc_dxtn: For Mesa S3TC support.')
-source=(
- local://LegendOfGrimrock-Linux-$_pkgdate.sh
- $pkgname.desktop
-)
-
-[ "$CARCH" != "i686" ] && _arch=x86_64 || {
- _arch=x86
- depends+=(gcc-libs-multilib)
-}
+license=("custom:commercial")
+depends=(freeimage minizip sdl libvorbis freetype2 zlib openal libgl libx11 libogg libxext desktop-file-utils)
+#optdepends=('libtxc_dxtn: For Mesa S3TC support.')
+# requires aur/lgogdownloader or the game file directly next to the PKGBUILD
+#DLAGENTS+=('gogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
+source=("${pkgname}"
+ "${pkgname}.desktop"
+ "gog_legend_of_grimrock_${pkgver}.sh::gogdownloader://legend_of_grimrock/en3installer3")
+sha256sums=('e72d4212b2394bd6038ac13ada2717756b4ce4a9370bbe96501ab1c489410861'
+ 'b93a443998d1fbe415c7228c7d173ea0226dabd028badbe0ce8f6f13a93de819'
+ 'c5fa1064977e4df4389d45be12a655f151227d08a22f3058bc4bc6e9627d1af1')
+# Disable compression of the package
+PKGEXT='.pkg.tar'
package() {
- sh ${source[0]//"local://"/} --tar xf
-
- _target=$pkgdir/usr/share/$pkgname
-
- mkdir -p $_target
- lzma -d < instarchive_linux_$_arch | tar xf - -C $_target
- lzma -d < instarchive_all | tar xf - -C $_target
-
- mkdir -p $pkgdir/usr/bin
- ln -s ../share/$pkgname/Grimrock.bin.$_arch $pkgdir/usr/bin/$pkgname
-
- install -D $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -d "${pkgdir}/opt/${pkgname}/"
+ install -d "${pkgdir}/opt/${pkgname}/support/"
+ install -d "${pkgdir}/usr/bin/"
+ install -d "${pkgdir}/usr/share/applications/"
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -d "${pkgdir}/usr/share/pixmaps/"
+
+ cp -r data/noarch/game/ "${pkgdir}/opt/${pkgname}/"
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
+
+ install -m 755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -m 755 data/noarch/start.sh "${pkgdir}/opt/${pkgname}/"
+ install -m 755 data/noarch/gameinfo "${pkgdir}/opt/${pkgname}/"
+ install -m 755 data/noarch/support/*.{sh,shlib} -t "${pkgdir}/opt/${pkgname}/support/"
+ install -m 644 'data/noarch/docs/End User License Agreement.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -m 644 "data/noarch/game/grimrock.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -m 644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
}
-
-sha256sums=('005066be6ce12ba342e499369070113c6b66a9bea03c6ecb1e5fd0758eb0c39d'
- 'a989d2d0d896ec4adaf3d66e19050c519d9e58efc8d588a51ab0185283bf21fb')
diff --git a/legend-of-grimrock b/legend-of-grimrock
new file mode 100644
index 000000000000..163b5b80cbf4
--- /dev/null
+++ b/legend-of-grimrock
@@ -0,0 +1,7 @@
+#!/usr/bin/env bash
+
+# https://github.com/mono/mono/issues/11557
+TERM=xterm /opt/legend-of-grimrock/start.sh "${@}"
+
+# vim: sw=2 ts=2 et:
+
diff --git a/legend-of-grimrock.desktop b/legend-of-grimrock.desktop
index cbc4ce25922d..3b11b4b5a220 100644
--- a/legend-of-grimrock.desktop
+++ b/legend-of-grimrock.desktop
@@ -2,6 +2,6 @@
Categories=Game;RolePlaying;
Encoding=UTF-8
Name=Legend of Grimrock
-Exec=/usr/bin/legend-of-grimrock
-Icon=/usr/share/legend-of-grimrock/grimrock.png
+Exec=legend-of-grimrock
+Icon=legend-of-grimrock
Type=Application