summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--0001-meson-Allow-building-with-system-orc.patch28
-rw-r--r--0002-HACK-meson-Disable-broken-tests.patch58
-rw-r--r--0003-HACK-meson-Work-around-broken-detection-of-underscor.patch24
-rw-r--r--PKGBUILD23
4 files changed, 123 insertions, 10 deletions
diff --git a/0001-meson-Allow-building-with-system-orc.patch b/0001-meson-Allow-building-with-system-orc.patch
new file mode 100644
index 000000000000..908174a48f80
--- /dev/null
+++ b/0001-meson-Allow-building-with-system-orc.patch
@@ -0,0 +1,28 @@
+From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
+Date: Mon, 6 Jun 2022 00:29:08 +0200
+Subject: [PATCH] meson: Allow building with system orc
+
+---
+ meson.build | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 617ba8a41461..509565e90891 100644
+--- a/meson.build
++++ b/meson.build
+@@ -112,7 +112,13 @@ elif build_system == 'darwin'
+ subproject('macos-bison-binary')
+ endif
+
+-orc_subproject = subproject('orc', required: get_option('orc'))
++orc_subproject_required = get_option('orc')
++if orc_subproject_required.allowed()
++ # Download if possible, otherwise use system orc
++ orc_subproject_required = false
++endif
++
++orc_subproject = subproject('orc', required: orc_subproject_required)
+
+ foreach custom_subproj: get_option('custom_subprojects').split(',')
+ if custom_subproj != ''
diff --git a/0002-HACK-meson-Disable-broken-tests.patch b/0002-HACK-meson-Disable-broken-tests.patch
new file mode 100644
index 000000000000..0aa801eacebd
--- /dev/null
+++ b/0002-HACK-meson-Disable-broken-tests.patch
@@ -0,0 +1,58 @@
+From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
+Date: Mon, 6 Jun 2022 00:30:08 +0200
+Subject: [PATCH] HACK: meson: Disable broken tests
+
+---
+ subprojects/gst-editing-services/meson.build | 1 -
+ subprojects/gst-python/meson.build | 1 -
+ subprojects/gst-rtsp-server/tests/check/meson.build | 1 -
+ subprojects/gstreamer-vaapi/meson.build | 1 -
+ 4 files changed, 4 deletions(-)
+
+diff --git a/subprojects/gst-editing-services/meson.build b/subprojects/gst-editing-services/meson.build
+index 1a4a29b3657f..857290baf35f 100644
+--- a/subprojects/gst-editing-services/meson.build
++++ b/subprojects/gst-editing-services/meson.build
+@@ -274,7 +274,6 @@ subdir('plugins')
+ if not get_option('tools').disabled()
+ subdir('tools')
+ endif
+-subdir('tests')
+ if not get_option('examples').disabled()
+ subdir('examples')
+ endif
+diff --git a/subprojects/gst-python/meson.build b/subprojects/gst-python/meson.build
+index dce5982e59d7..ed51d7e88f36 100644
+--- a/subprojects/gst-python/meson.build
++++ b/subprojects/gst-python/meson.build
+@@ -104,5 +104,4 @@ if not get_option('plugin').disabled()
+ endif
+ endif
+ if not get_option('tests').disabled()
+- subdir('testsuite')
+ endif
+diff --git a/subprojects/gst-rtsp-server/tests/check/meson.build b/subprojects/gst-rtsp-server/tests/check/meson.build
+index 229af32f8117..b9372c125d77 100644
+--- a/subprojects/gst-rtsp-server/tests/check/meson.build
++++ b/subprojects/gst-rtsp-server/tests/check/meson.build
+@@ -27,7 +27,6 @@ rtsp_server_tests = [
+ 'gst/mediafactory',
+ 'gst/media',
+ 'gst/permissions',
+- 'gst/rtspserver',
+ 'gst/sessionmedia',
+ 'gst/sessionpool',
+ 'gst/stream',
+diff --git a/subprojects/gstreamer-vaapi/meson.build b/subprojects/gstreamer-vaapi/meson.build
+index 702441cb7b5c..9fff27ce91b9 100644
+--- a/subprojects/gstreamer-vaapi/meson.build
++++ b/subprojects/gstreamer-vaapi/meson.build
+@@ -202,7 +202,6 @@ plugins = []
+
+ subdir('gst-libs')
+ subdir('gst')
+-subdir('tests')
+ subdir('docs')
+
+ # Set release date
diff --git a/0003-HACK-meson-Work-around-broken-detection-of-underscor.patch b/0003-HACK-meson-Work-around-broken-detection-of-underscor.patch
new file mode 100644
index 000000000000..6883c6fed194
--- /dev/null
+++ b/0003-HACK-meson-Work-around-broken-detection-of-underscor.patch
@@ -0,0 +1,24 @@
+From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
+Date: Mon, 6 Jun 2022 00:30:08 +0200
+Subject: [PATCH] HACK: meson: Work around broken detection of underscore
+ prefixes
+
+See: https://github.com/mesonbuild/meson/issues/5482
+---
+ subprojects/gst-plugins-good/gst/deinterlace/meson.build | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/subprojects/gst-plugins-good/gst/deinterlace/meson.build b/subprojects/gst-plugins-good/gst/deinterlace/meson.build
+index e86bebe613fc..96a961107ab6 100644
+--- a/subprojects/gst-plugins-good/gst/deinterlace/meson.build
++++ b/subprojects/gst-plugins-good/gst/deinterlace/meson.build
+@@ -54,8 +54,6 @@ if have_nasm and host_cpu == 'x86_64'
+ # https://github.com/mesonbuild/meson/issues/5482
+ if ['darwin', 'ios'].contains(host_system)
+ asm_prefix_def = '-DPREFIX'
+- elif cc.symbols_have_underscore_prefix()
+- asm_prefix_def = '-DPREFIX'
+ else
+ asm_prefix_def = '-UPREFIX'
+ endif
diff --git a/PKGBUILD b/PKGBUILD
index 257ece4838a2..2b99fa09c1b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,7 +19,7 @@ pkgname=(
lib32-gstreamer-vaapi-git
)
-pkgver=1.20.2
+pkgver=1.20.3
pkgrel=1
pkgdesc="Multimedia graph framework (32-bit)"
url="https://gstreamer.freedesktop.org/"
@@ -64,12 +64,16 @@ options=(debug)
source=(
"git+https://gitlab.freedesktop.org/gstreamer/gstreamer.git?signed#tag=$pkgver"
"https://gstreamer.freedesktop.org/src/gstreamer-docs/gstreamer-docs-$pkgver.tar.xz"{,.asc}
+ 0001-meson-Allow-building-with-system-orc.patch
+ 0002-HACK-meson-Disable-broken-tests.patch
+ 0003-HACK-meson-Work-around-broken-detection-of-underscor.patch
)
-sha256sums=(
- 'SKIP'
- 'ca70d921cbbba9fe17679b47d2e0db886e0422d37652837a170d76c3f2b4bc53'
- 'SKIP'
-)
+sha256sums=('SKIP'
+ '73fc428a40d6a34c2ceb80e3e572b20f19f8ebe216d566f010de11573063f1bf'
+ 'SKIP'
+ '292edebc224557db08404b0d53e2824413f0aad2a99c991de2cb8ccc6e9a7683'
+ '11971a978e37fda3822f95fb61b59ba3ded6487066dc59fcbde7b72a3a9cfe70'
+ '79d3038a0ba0c3958ffa8b5aec8431336b372906c07c0c878c3767bec0acb46f')
validpgpkeys=(D637032E45B8C6585B9456565D2EEE6F6F349D7C) # Tim Müller <tim@gstreamer-foundation.org>
pkgver() {
@@ -81,15 +85,14 @@ prepare() {
cd gstreamer
# Fix linking with system orc
- sed -i "s/get_option('orc')/false/" meson.build
+ git apply -3 ../0001-meson-Allow-building-with-system-orc.patch
# Disable broken tests
- sed -i "/subdir('tests')/d" subprojects/{gst-editing-services,gstreamer-vaapi}/meson.build
- sed -i "/'gst\/rtspserver'/d" subprojects/gst-rtsp-server/tests/check/meson.build
+ git apply -3 ../0002-HACK-meson-Disable-broken-tests.patch
# Workaround broken detection of underscore prefixes
# https://github.com/mesonbuild/meson/issues/5482
- sed -i 's/-DPREFIX/-UPREFIX/' subprojects/gst-plugins-good/gst/deinterlace/meson.build
+ git apply -3 ../0003-HACK-meson-Work-around-broken-detection-of-underscor.patch
}
build() {